[Tex-nl] foutmelding texlive 2017

Wilfred van Rooijen wvanrooijen at yahoo.com
Wed Nov 8 13:13:56 CET 2017


Ik hou de ontwikkelingen van XeTeX en LuaTeX niet meer gedetailleerd bij, maar in Die Goede Oude Tijd was het als volgt:
XeTeX <-> fontspec <-> polyglossia
versus
pdfLaTeX <-> babel
Zowel XeTeX als LuaTeX gebruiken UTF-8 als codering en kunnen dus alle alfabetten aan maar ik heb de indruk dat je "XeTeX-achtige" dingen als fonstpec en polyglossia beter niet gebruikt met LuaTeX. Maar zoals gezegd, ik hou de ontwikkelingen niet zo bij dus misschien dat het tegenwoordig wel allemaal goed samen kan werken.

Groeten,Wilfred
 

    On Wednesday, November 8, 2017 6:27 AM, Piet van Oostrum <piet-l at vanoostrum.org> wrote:
 

 Ernst van der Storm schreef:

 > Beste ntg'ers
 > 
 > Ik heb texlive 2017 op mijn debian jessie geïnstalleerd en krijg nu:
 > Compiling...Messages for file /usr/local/texlive/2017/texmf-dist/tex/latex/fontspec/
 > fontspec-luatex.sty:
 > !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
 > !
 > ! LaTeX error: "kernel/command-already-defined"
 > !
 > ! Control sequence \latinencoding already defined.
 > !
 > ! See the LaTeX3 documentation for further information.
 > !
 > ! For immediate help type H <return>.
 > !............................................... 
 > l.121 \tl_new:N \latinencoding
 > file: /usr/local/texlive/2017/texmf-dist/tex/latex/fontspec/fontspec-luatex.sty
 > line 121: \tl_new:N \latinencoding
 > 10 errors
 > 
 > met tlmgr update -all geen verbetering.
 > 
 > Wat moet ik doen om e.e.a. werkend/gecompileerd te krijgen?
 > Ik heb nog geen m.w.e., helaas, en 
 > https://tex.stackexchange.com/questions/380492/compiling-error-l3experimental-kernel-command-already-defined
 > levert niets beters op.
 > Ik heb nu de betreffende regel (121) in /usr/local/texlive/2017/texmf-dist/tex/latex/fontspec/
 > fontspec-luatex.sty met %% uitgeschakeld, maar dat lijkt mij niet de juiste manier. Compilatie
 > werkt wel, nu.
 > 
 > Heeft iemand betere suggesties?

Schijnt een nieuw geïntroduceerde bug te zijn i.s.m. babel (gisteren gerapporteerd). 
Eerst fontspec laden, dan babel.
Alternatief:
\usepackage[english]{babel} 
\let\latinencoding\relax 
\usepackage{fontspec}
-- 
Piet van Oostrum <piet-l at vanoostrum.org>
WWW: http://piet.vanoostrum.org/
PGP key: [8DAE142BE17999C4]

_______________________________________________
TeX-NL mailing list
TeX-NL at ntg.nl
https://mailman.ntg.nl/mailman/listinfo/tex-nl


   
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mailman.ntg.nl/pipermail/tex-nl/attachments/20171108/80cd0f29/attachment-0001.html>


More information about the TeX-NL mailing list