[Tex-nl] foutmelding texlive 2017

Siep Kroonenberg siepo at cybercomm.nl
Tue Nov 7 12:38:21 CET 2017


On Tue, Nov 07, 2017 at 11:28:31AM +0100, Ernst van der Storm wrote:
> Beste ntg'ers
> 
> Ik heb texlive 2017 op mijn debian jessie geïnstalleerd en krijg nu:
> Compiling...Messages for file
> /usr/local/texlive/2017/texmf-dist/tex/latex/fontspec/fontspec-luatex.sty:
> !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
> !
> ! LaTeX error: "kernel/command-already-defined"
> !
> ! Control sequence \latinencoding already defined.
> !
> ! See the LaTeX3 documentation for further information.
> !
> ! For immediate help type H <return>.
> !...............................................
> l.121 \tl_new:N \latinencoding
> file:
> /usr/local/texlive/2017/texmf-dist/tex/latex/fontspec/fontspec-luatex.sty
> line 121: \tl_new:N \latinencoding
> 10 errors
> 
> met tlmgr update -all geen verbetering.
> 
> Wat moet ik doen om e.e.a. werkend/gecompileerd te krijgen?
> Ik heb nog geen m.w.e., helaas, en https://tex.stackexchange.com/questions/380492/compiling-error-l3experimental-kernel-command-already-defined
> levert niets beters op.
> Ik heb nu de betreffende regel (121) in
> /usr/local/texlive/2017/texmf-dist/tex/latex/fontspec/fontspec-luatex.sty
> met %% uitgeschakeld, maar dat lijkt mij niet de juiste manier. Compilatie
> werkt wel, nu.
> 
> Heeft iemand betere suggesties?

Wat algemene dingen:

1. Kijk in de logfile of alle LaTeX files inderdaad uit de TeX Live
installatie komen en geen verdwaalde exemplaren zijn.

2. Kijk ook in de lijst van aangeroepen packages of je ze inderdaad
nodig hebt. De volgorde kan ook wel eens wat uitmaken.

3. En tenslotte is er luatex85.sty voor compatibiliteit met oudere
luatex versies.

-- 
Siep Kroonenberg


More information about the TeX-NL mailing list