[Tex-nl] Probleem met spaanse leestekens in Source Sans Pro

Bas Dekker (TeXniek) texnics at digifuga.nl
Mon May 8 12:41:16 CEST 2017


Beste vrienden, 


Ik heb hier een issue waar ik mijn tanden op stukbijt. 

Als volgt: ik moet een stuk in het Spaans TeX-en. Ik gebruik XeLaTeX want ik moet ook een Adobe Font gebruiken: Source Sans Pro. 

ik heb een andere constraint: de input file moet in 7-bits. Dan denk voor die omgekeerde leestekens: teken - backtick.

Ik heb wat lopen proberen. Hier is een MWE:

\documentclass{article}
%\usepackage[utf8]{inputenc}
\usepackage{fontspec}
\setmainfont{Source Sans Pro}
%\DeclareUnicodeCharacter{00BF}{\como}
\begin{document}
¿ Como est\'as ?

?` Como est\'as ?
%\como{} Como est\'as ?
\end{document}


Als ik fontspec en setmainfont uitzet, dan krijg ik keurig in beide regels een omgekeerd vraagteken

Als ik ze aanzet, dan weigert hij ?` te interpreteren. Ik krijg dan gewoon twee glyphs. Het probleem is dat ik _echt_ 7 bits moet zijn. 

Ik heb zoals jullie zien geprobeerd om met inputenc (ja, ik weet het, het mag niet met XeLateX) te regelen dat ik een commando aanmaak voor dat specifieke character, maar dan zegt hij 

"DeclareUnicodeCharacter: Undefined Control Sequence"

Dus maar weer uitgecommentarieerd. Dat is een weer een ander probleem, maar goed...

Het is toch wel heel erg gek, want hij kent de glyph wel degelijk, maar ik krijg hem maar niet in 7-bits uitprint. Misschien iets mis met mijn backtick-glyph in Source Sans Pro, aangezien het in het reguliere font wél werkt? Al zou ik niet weten wat...

Ik heb "gewoon" een commando nodig dat in 7-bits die twee kl*tetekens uitprint ;-)

Iemand een idee?

Bedankt alvast!





Bas Dekker 
(sub-account voor TeXniek)

Postbus 11088
1001 GB Amsterdam

+31 (0)6 25 00 32 78

texnics at digifuga.nl








-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mailman.ntg.nl/pipermail/tex-nl/attachments/20170508/ee769c8d/attachment.html>


More information about the TeX-NL mailing list