[Tex-nl] locatie lco files

Wilfred van Rooijen wvanrooijen at yahoo.com
Tue Feb 4 12:31:43 CET 2014


Het is een bekend LaTeX-probleem. De .aux file bevat informatie voor de referenties, citaties, e.d.. Bij elke run wordt gekeken of er een .aux file is en de informatie wordt dan gelezen. Het kan gebeuren dat je om wat voor reden dan ook een "foute" latex run hebt gedaan, waardoor er onzin in de .aux file terecht is gekomen. Bij iedere volgende compilatie gaat het dan fout.

Als je een "full blown" latex document hebt moet je soms wel 4 of 5 keer compileren voordat alles goed staat. Bijvoorbeeld referenties vereisen minstens 2 keer compileren: de eerste keer om de referentielijst op te bouwen en de tweede keer om de lijst te gebruiken. Als je bibtex gebruikt moet je vaak nog een keer extra om alle citaties goed te zetten. En als je ook nog dingen gebruikt als hyperref, index, nomenclatuur, etc, dan kan het gebeuren dat je een aantal keer moet compileren.

Groeten,
Wilfred

Overigens, als de latex-run niet volledig is, wordt er ook geen nieuwe PDF gemaakt. De meeste "automatische" tools detecteren vaak niet goed of de latex-run goed is gegaan, en dergelijke tools openen de PDF altijd. Met andere woorden: als latex crasht kijk je steeds naar de __oude__ PDF als die beschikbaar is. Bijvoorbeeld MiKTeX op Windows heeft daar een handje van.





On Tuesday, February 4, 2014 5:59 PM, Rejo Zenger <rejo at zenger.nl> wrote:
 
++ 03/02/14 17:28 -0800 - Wilfred van Rooijen:
>
>>Zoals Piet ook al opmerkte: dit is een fout in babel. Het lijkt erop dat de template file wel degelijk wordt gevonden. Verwijder alle bestanden behalve de .tex file (dus test.aux, test.blg, test.toc, test.lot, test.lof, test.pdf, test.log, etc) en probeer het nog eens. Als deze babel-fout blijft, dan heb je een verkeerde instelling in the template staan.
>
>Ik ging er vanuit dat het LCO-bestand niet gevonden kon worden én dat 
>het LCO-bestand verder in orde is omdat het PDF-bestand wel netjes wordt 
>gegenereerd als beide in dezelfde directory staan. 
>
>Je suggestie werkt: alles verwijderen met uitzondering van test.tex en 
>dan nog eens opnieuw proberen. Ik vind dat niet bepaald intuïtief. Dank 
>voor de oplossing. 
>
>Nu heb ik nog tal van andere kleine punten om te fixen, maar de basis 
>staat. :)
>
>-- 
>Rejo Zenger . <rejo at zenger.nl> . 0x21DBEFD4 . <https://rejo.zenger.nl>
>GPG encrypted e-mail preferred . +31.6.39642738 . @rejozenger
>_______________________________________________
>TeX-NL mailing list
>TeX-NL at ntg.nl
>http://www.ntg.nl/cgi-bin/mailman/listinfo/tex-nl
>
>
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.ntg.nl/pipermail/tex-nl/attachments/20140204/118fe2f7/attachment.html>


More information about the TeX-NL mailing list