[Tex-nl] Extra afbreekpatronen werken niet

Hans Hagen pragma at wxs.nl
Wed Jan 2 14:45:03 CET 2013


On 1/2/2013 11:27 AM, Piet van Oostrum wrote:
> Hans Hagen wrote:
>
>   > On 1/1/2013 4:06 PM, Pander wrote:
>   >
>   > >> TeX breekt alleen woorden af die voorafgegaan worden door "glue" (bijvoorbeeld een spatie) en zo zijn er nog wat voorwaarden. Daarom worden woorden die aan het begin van een regel staan niet afgebroken.  En in het algemeen is dat ook niet nodig omdat woorden meestal korter zijn dan de regel.
>   >
>   > dat geldt niet voor luatex dat lange eerste woorden wel afbreekt
>   >
> Zijn er nog meer verschillen tussen de afbreking van LuaTeX en die van het traditionele TeX?

- runtime laden van patronen
- alles is unicode (utf input)
- geen koppeling meer met fonts maar language property in glyph nodes
- alles wordt vooraf afgebroken, dus niet alleen de meest voor de hand 
liggende plekken (tijdens de par builder)
- alle relevante taal info reist mee met een glyph node (dus lokale taal 
switches zijn completer)
- dynamisch mem management en dus ook meer exceptions
- wat meer \*hyphenchar primitieven
- ontkoppeling ligatures en hyphenation (geen rebuil dnodig)

en misschien nog wat

Hans

-----------------------------------------------------------------
                                           Hans Hagen | PRAGMA ADE
               Ridderstraat 27 | 8061 GH Hasselt | The Netherlands
     tel: 038 477 53 69 | voip: 087 875 68 74 | www.pragma-ade.com
                                              | www.pragma-pod.nl
-----------------------------------------------------------------



More information about the TeX-NL mailing list