[Tex-nl] Extra afbreekpatronen werken niet

Piet van Oostrum piet at vanoostrum.org
Sun Dec 30 00:14:34 CET 2012


Pander wrote:

 > Hoi allemaal,
 > 
 > Ik gebruik met de laatste versie van TeX Live in XeLaTeX het volgende:
 > 
 > %!xelatex
 > \documentclass{memoir}
 > \usepackage{multicol}
 > \usepackage{polyglossia}
 > \setdefaultlanguage{dutch}
 > \hyphenation{aan-spra-ke-lijk-heids-ver-ze-ke-rings-maat-schap-pij
 > ar-beids-on-ge-schikt-heids-ver-ze-ke-rings-maat-schap-pij
 > be-roeps-aan-spra-ke-lijk-heids-ver-ze-ke-ring
 > com-mis-sa-ris-sen-aan-spra-ke-lijk-heids-ver-ze-ke-ring
 > pro-du-cen-ten-aan-spra-ke-lijk-heids-ver-plich-ting}%FIXME
 > \begin{document}
 > \begin{multicols}{2}
 > aansprakelijkheidsverzekeringsmaatschappij\\
 > arbeidsongeschiktheidsverzekeringsmaatschappij\\
 > beroepsaansprakelijkheidsverzekering\\
 > commissarissenaansprakelijkheidsverzekering\\
 > producentenaansprakelijkheidsverplichting
 > \end{multicols}
 > \end{document}
 > 
 > Maar er wordt niet afgebroken. Hoe krijg ik dit wel voor elkaar?
 > 
Je hebt natuurlijk wel een erg kunstmatig voorbeeld gecreëerd en dat is het probleem hier. TeX breekt alleen woorden af die voorafgegaan worden door "glue" (bijvoorbeeld een spatie) en zo zijn er nog wat voorwaarden. Daarom worden woorden die aan het begin van een regel staan niet afgebroken.  En in het algemeen is dat ook niet nodig omdat woorden meestal korter zijn dan de regel.

Je kunt de afbreking in dit geval mogelijk maken door de woorden te laten voorafgaan door glue, bijvoorbeeld door het woord "de" ervoor te zetten, of door ze te laten voorafgaan door expliciete glue zoals \hskip 0pt plus 0pt.

En verder allemaal een gelukkig nieuwjaar gewenst.
-- 
Piet van Oostrum <piet at vanoostrum.org>
WWW: http://pietvanoostrum.com/
PGP key: [8DAE142BE17999C4]



More information about the TeX-NL mailing list