[NTG-pdftex] vf font expansion bug

Hans Hagen j.hagen at xs4all.nl
Thu Mar 26 23:46:22 CET 2020


On 3/26/2020 10:49 PM, Karl Berry wrote:
>      something "no expansion applied to virtual font 'foo'" or so ... just to
>      prevent some question about a possible bug coming up 5 years from now
> 
> My understanding is that there was nothing wrong with what Robert is
> doing (though it is unusual). Therefore I see no reason for a
> message. The prior behavior was just a bug. pdftex should simply behave
> correctly. What am I missing?

i'm just puzzled by the fact that it could occur in the first place: a 
font needs to be configured (expansion parameters), somehow looks for 
some instance (file or so) being present and when not crashed the 
engine; sure, the null check fixes is, but it might kind of obscures the 
real issue as that branch was entered (the -20-100 kind of looks 
suspicious), but let's now waste time on it because maybe i just don't 
understand it well enough

> As for posterity, there are ChangeLog entries, VC logs, this mail
> thread, notes in the code ... -k
sure (it's just my experience that not that many users look at those so 
questions pop up again, which is why i often just add messages for the 
sake of that; ok no one ran into this issue so far, so we can ignore it 
here, an d most folks won't notice an issue with hz anyway because on a 
display it's sub pixel)

Hans

-----------------------------------------------------------------
                                           Hans Hagen | PRAGMA ADE
               Ridderstraat 27 | 8061 GH Hasselt | The Netherlands
        tel: 038 477 53 69 | www.pragma-ade.nl | www.pragma-pod.nl
-----------------------------------------------------------------


More information about the ntg-pdftex mailing list