[NTG-pdftex] [pdftex-Bugs][4341] Stream dictionary improperly formatted

pdftex-bugs at sarovar.org pdftex-bugs at sarovar.org
Wed Jul 20 20:48:35 CEST 2011

Bugs item #4341, was opened at 2011-07-14 00:38
Status: Open
Priority: 3
Submitted By: Vincent Immler (vini)
Assigned to: Nobody (None)
Summary: Stream dictionary improperly formatted 
Category: Primitives
Group: v1.40.8
Resolution: Works For Me

Initial Comment:
Testing with: Acrobat 9.4.5 (Mac/US-EN) and pdftex-1.40.11 (TeXLive2010):

Running Acrobat's preflight using "Verify compliance with PDF/A-1b" results in several errors. It appears to me, that Adobe has changed something, as it worked worked some time ago (at least for me with an older version of both Acrobat and pdftex).

Preflight complains about the following:
[X] Syntax problem: Indirect object "endobj" keyword not preceded by an EOL marker
[X] Syntax problem: Indirect object "obj" keyword not followed by an EOL marker
[X] Syntax problem: Stream dictionary improperly formatted

The appended patch applies to pdftex.web and solves the first two problems. The third one is not solved yet and only occurs when including XMP data (could be a problem with xmpincl.sty or the provided xmp data file).


>Comment By: The Thanh Han (hanthethanh)
Date: 2011-07-20 18:48

thanks for playing with this.  Yes this is a known problem and I got stuck with this; the stream seems to be ok but yet AR9 is not happy (AR8 was ok).  More thorough testing needed.


Comment By: Vincent Immler (vini)
Date: 2011-07-20 10:38

In the meantime, I checked out the SVN version for tagged-pdf and found out, that this problem seems to be known already. However, the tagged-pdf branch does not work for me.

I was now able to solve the problem by forcing the EOL character to be 13 before each "endstream" instead of 10.

pdf_seek_write_length := false;

(I'm quite sure, this is not well-thought-out, but it works :-))

Using this modification in addition to the aforementioned two small modifications allows me to generate PDFA-1b compliant documents according to Acrobat 9.4.5.


Comment By: Vincent Immler (vini)
Date: 2011-07-14 12:14

I made progress in solving the last problem and found out, that it does not seem to be related to pdftex.
To my best knowledge, it is because of xmpincl.sty when generating the xmpi file for inclusion. The way how the .xmp is read needs to be improved and I'm currently working on that.


Comment By: Vincent Immler (vini)
Date: 2011-07-14 00:56

Just attached a PDF that has the error, so you can check.


You can respond by visiting: 

More information about the ntg-pdftex mailing list