[NTG-pdftex] [ pdftex-Bugs-874 ] problem with writettf?

noreply at sarovar.org noreply at sarovar.org
Fri Oct 12 09:54:58 CEST 2007


Bugs item #874, was opened at 2007-10-11 14:34
You can respond by visiting: 
http://sarovar.org/tracker/?func=detail&atid=493&aid=874&group_id=106

Category: Fonts
Group: v1.40.5
Status: Open
Resolution: None
Priority: 5
Submitted By: Stefan Becuwe (sbecuwe)
Assigned to: Hartmut Henkel (hhenkel)
Summary: problem with writettf?

Initial Comment:
Hello

I'm using texlive 2007 and encountered the following
problem with a truetype font:

[...]
{/usr/local/apps/texlive-2007/texmf/fonts/enc/ttf2pk/ba
se/T1-WGL4.enc}<Auto1-Light.ttfpdflatex:
../../../../texk/web2c/pdftexdir/writettf.c:848:
prepend_subset_tags: Assertion `index > 0 && index <
name_record_num && fd_cur->subset_tag != ((void *)0)'
failed.

Upgrading pdftex to 1.40.5 still produces the same
error.   

My previous texlive version (2005 or 2006) didn't have
that problem.  Replacing Auto1-Light.ttf by another
ttf, such as technicn.ttf, does not result in an error.
 So it's probably related to the Auto1-Light.ttf file
itself, but it seems the behaviour of pdftex has
changed over the years...

Best regards


Stefan

----------------------------------------------------------------------

>Comment By: Stefan Becuwe (sbecuwe)
Date: 2007-10-12 09:54

Message:
Logged In: YES 
user_id=4723

Changing index > 0  into  index >= 0  did solve the problem.
 I have attached anyway the minimal testcase (generated
after the suggested patch).  Thanks for solving this problem!


Stefan

----------------------------------------------------------------------

Comment By: Martin Schröder (oneiros)
Date: 2007-10-11 19:21

Message:
Logged In: YES 
user_id=421

Can you create a minimal testcase and attach it here
together with the font? systems/mkjobtexmf from CTAN might
be helpful.

----------------------------------------------------------------------

Comment By: Hartmut Henkel (hhenkel)
Date: 2007-10-11 16:14

Message:
Logged In: YES 
user_id=929

does it go away if you change in pdftex-1.40.5, writettf.c
in function prepend_subset_tag() the line assert(index >
0... into assert(index >= 0...?

----------------------------------------------------------------------

You can respond by visiting: 
http://sarovar.org/tracker/?func=detail&atid=493&aid=874&group_id=106


More information about the ntg-pdftex mailing list