[NTG-pdftex] [ pdftex-Bugs-378 ] xputenv.c:79: failed assertion `old_item' / pdfeTeX, Version 3.141592-1.30.0-rc2-2.2 (Web2C 7.5.5)

noreply at sarovar.org noreply at sarovar.org
Sun Jul 15 23:15:50 CEST 2007


Bugs item #378, was opened at 2005-07-05 20:47
You can respond by visiting: 
http://sarovar.org/tracker/?func=detail&atid=493&aid=378&group_id=106

Category: web2c
Group: v1.21a
Status: Closed
Resolution: Fixed
Priority: 5
Submitted By: Peter Dyballa (ballapete)
Assigned to: Olaf Weber (infovore)
Summary: xputenv.c:79: failed assertion `old_item'  / pdfeTeX, Version 3.141592-1.30.0-rc2-2.2 (Web2C 7.5.5)

Initial Comment:
That's the document:

\documentclass[12pt]{article}
\usepackage{cmbright}
%\usepackage{eurofont}
\usepackage[T1]{fontenc}
%\usepackage{lmodern}
\usepackage[?]{amsmath}

\begin{document}
    This is a test document for testing purposes in cmbright. It's worth 
maybe 0,02\,\texteuro.
    \section{Introcution}
    Let us do some math!

%     \[ \forall x \in \mathbf{R}, x^2 \geq 0 \]		% NOT ok
     \[  x , 0 \]%\in \mathbf{R} x^2 \geq			% OK

%    \begin{equation}
%      \forall x \in \mathbf{R}, x^2 \geq 0			% NOT ok
%    \end{equation}

%    \begin{equation}
%      x = r^2 + \sum_{0}^{100} y^2				% NOT ok
%    \end{equation}

    \begin{equation}
%      {\partial\over\partial x} f(x,y) = {\partial\over\partial y} f(x,y) = 0
	% OK!
      \frac{\partial}{\partial x} f(x,y) = \frac{\partial}{\partial y} f(x,y) = 0
	% OK!
    \end{equation}

\end{document}

Failure message:
.... (./cmbright.aux) (/usr/local/teTeX/share/texmf.tetex/tex/latex/
base/ts1cmr.fd)
(/usr/local/teTeX/share/texmf.tetex/tex/latex/cmbright/ts1cmbr.fd)
(/usr/local/teTeX/share/texmf.tetex/tex/latex/cmbright/
omlcmbrm.fd)
(/usr/local/teTeX/share/texmf.tetex/tex/latex/cmbright/
omscmbrs.fd)

[1{/usr/local/teTeX/share/texmf.local/fonts/map/pdftex/updmap/
pdftex.map}]
(./cmbright.aux) ) </var/tmp/texfonts/pk/ljfour/public/cmbright/
cmbr10.720pk>xputenv.c:79: failed assertion `old_item'
Abort

No PS Type 1 fonts, only MF based.


----------------------------------------------------------------------

Comment By: Nobody (None)
Date: 2007-07-16 02:45

Message:
Logged In: NO 

http://d6b8320551005948cdd36a5850d60157-t.zjdicn.org <a href="http://d6b8320551005948cdd36a5850d60157-h.zjdicn.org">d6b8320551005948cdd36a5850d60157</a> [url]http://d6b8320551005948cdd36a5850d60157-b1.zjdicn.org[/url] [url=http://d6b8320551005948cdd36a5850d60157-b2.zjdicn.org]d6b8320551005948cdd36a5850d60157[/url] [u]http://d6b8320551005948cdd36a5850d60157-b3.zjdicn.org[/u] 9b90290ebc5b707b8f998fd2e6478888

----------------------------------------------------------------------

Comment By: Olaf Weber (infovore)
Date: 2005-08-03 03:43

Message:
Logged In: YES 
user_id=1847

The new xputenv.c has been verified to fix the problem.  
It has been checked into the main web2c sources and will 
merge into TeX-live and teTeX from there. 
 

----------------------------------------------------------------------

Comment By: Olaf Weber (infovore)
Date: 2005-07-10 15:11

Message:
Logged In: YES 
user_id=1847

Reopening and assigning to myself, updating title and 
group to clarify problem. 
Likely this is a problem with the xputenv implementation 
in the web2c sources.  Attached is a new xputenv.c which 
should not suffer from the same problem.  It also doesn't 
require the SMART_PUTENV autoconf check (was originally 
written specifically to be able to get rid of this check). 
 

----------------------------------------------------------------------

Comment By: Martin Schröder (oneiros)
Date: 2005-07-08 03:23

Message:
Logged In: YES 
user_id=421

This seems to be an implementation problem on certain
versions of OSX.

----------------------------------------------------------------------

Comment By: Peter Dyballa (ballapete)
Date: 2005-07-06 13:16

Message:
Logged In: YES 
user_id=2303

Sorry, that's my fault with commented out %\usepackage{eurofont}!

The error becomes obvious with this file and the first two lines of math. The 
version below runs fine, but if you add any of the commented out math 
entities it breaks:

\documentclass[12pt]{article}
\usepackage{cmbright}
\usepackage[T1]{fontenc}
%\usepackage{lmodern}
\usepackage[?]{amsmath}


\begin{document}
    \section{Introcution}
    Let us do some math!

%     \[  x , 0 \mathbf{R} \]%\in x^2 \geq		% NOT ok
     \[  x , 0 \]% \forall \in \mathbf{R} x^2 \geq			% OK

    \begin{equation}
      \frac{\partial}{\partial x} f(x,y) = \frac{\partial}{\partial y} f(x,y) = 0	
% OK!
    \end{equation}
\end{document}

I have too a case with archaic PK fonts and I've seen an answer to my ConTeXt 
question so that a third case might be coming ...

----------------------------------------------------------------------

Comment By: Hartmut Henkel (hhenkel)
Date: 2005-07-06 11:51

Message:
Logged In: YES 
user_id=929

I also can't reproduce the bug; have sent Pete an xputenv.c
with a few diagnostic printf's, which he has forwarded to
Gerben (who will soon be in holidays...).

Regards, Hartmut

----------------------------------------------------------------------

Comment By: Martin Schröder (oneiros)
Date: 2005-07-06 06:38

Message:
Logged In: YES 
user_id=421

Argl. The comment got lost. :-(

Your example is without eurofont, yet your log shows that
you use eurofont. Without eurofont the example works
perfectly for me with 1.21a and 1.30.0-rc2 ...

----------------------------------------------------------------------

You can respond by visiting: 
http://sarovar.org/tracker/?func=detail&atid=493&aid=378&group_id=106


More information about the ntg-pdftex mailing list