[NTG-pdftex] [ pdftex-Patches-474 ] Use dynamically linked poppler library instead of xpdf code

noreply at sarovar.org noreply at sarovar.org
Mon Jan 30 17:53:16 CET 2006


Patches item #474, was opened at 2006-01-30 17:53
You can respond by visiting: 
http://sarovar.org/tracker/?func=detail&atid=495&aid=474&group_id=106

Category: None
Group: None
Status: Open
Resolution: None
Priority: 5
Submitted By: Frank Küster (frank)
Assigned to: Nobody (None)
Summary: Use dynamically linked poppler library instead of xpdf code

Initial Comment:
This has already been applied and tested in Debian and
Ubuntu, but we suggest to apply it upstream.  There are
a few things to do, however, as Martin already pointed
out to me in a private mail.  I paraphrase the main points:

- the pdftex distribution should not ship libpoppler.
Instead it should be possible to switch from xpdf to
libpoppler using autoconf magic, if libpoppler headers
are installed.  This needs some coding work

- We need a common API for xpdf and poppler.  This is
the tricky part, because the very reason for poppler's
existence is that the xpdf developer, Derek Noonburg,
refuses any patches that would lead to a shared
library. As Martin said, "for the beginning, a header
file with a couple of #ifdef'ed definitions should be
enough".

I'm going to subscribe to the pdftex devel list soon,
but am not yet subscribed currently.

----------------------------------------------------------------------

You can respond by visiting: 
http://sarovar.org/tracker/?func=detail&atid=495&aid=474&group_id=106


More information about the ntg-pdftex mailing list