[NTG-pdftex] pdftex-1.30.2 is broken

Thanh Han The hanthethanh at gmail.com
Thu Sep 1 18:40:11 CEST 2005


Hi Martin,

I uploaded the log files to pdftex.sarovar.org/misc/log.zip

After some tries I found that that when shell_escape is set
to 'f' then there is a problem with the new version but not
with the old version. However when it is set to 't' then the
problem went away in both versions.

Maybe the old version should fail as well and this is not a
new bug but a bug discovery in the old version :)

kpathsea experts probably can tell more what went wrong.

Thanh


On Thu, Sep 01, 2005 at 05:24:24PM +0200, The Thanh Han wrote:
> On Wed, Aug 31, 2005 at 01:27:05PM +0200, Martin Schr?der wrote:
> > On 2005-08-29 15:38:44 -0700, Thanh Han The wrote:
> > > it seems that pdftex-1.30.2 is broken. When I run it on a
> > > rather complex document, it couldn't find some files in the
> > > current directory or in the standard texmf tree. This
> > > doesn't happen with 1.30.0. I am sorry that I cannot send
> > > the files to reproduce the bug. The error happens randomly
> > > and took me a few hours before I tried to run 1.30.0 against
> > > it.
> > 
> > Do you have more details? Has anybody else seen the same
> > problems?
> 
> Radhakrisnan has experienced the same problem on Mac OSX,
> with pdftex binaries built from sources. Plus another guy
> with Linux Redhat i386.
> 
> I have been gazing at the diff in sources in 1.30.0 and
> 1.30.2, but couldn't find anything that seem suspicious.
> 
> I will try to make some set of log files from kpathsea for
> comparison. Maybe Olaf or Karl can find something wrong.
> 
> Thanh


More information about the ntg-pdftex mailing list