[NTG-pdftex] [ pdftex-Bugs-450 ] error copying .pfb font to pdf

noreply at sarovar.org noreply at sarovar.org
Wed Nov 9 23:29:43 CET 2005


Bugs item #450, was opened at 2005-11-09 20:33
You can respond by visiting: 
http://sarovar.org/tracker/?func=detail&atid=493&aid=450&group_id=106

Category: Fonts
Group: v1.21a
Status: Open
Resolution: None
Priority: 5
Submitted By: Christian Heusquin (chrisheus)
Assigned to: Hartmut Henkel (hhenkel)
Summary: error copying .pfb font to pdf

Initial Comment:
I'm an user of MikTeX package (vers 2.4) and uses 
pdfLaTeX on a regular basis.

I bought a Poscript Type 1 Sabon Font family from 
Monotype and when using the italic (msbri8a.pfb) 
pdfeTex has a problem and stops writing output. The 
pdf is unusable.

I checked the .pfb and its Ok. I can use it with 
Latex but then I have other problems (graphics, and 
symbol fonts).

Here is an extract of the log file:

This is pdfeTeX, Version 3.141592-1.21a-2.2 (MiKTeX 
2.4) (preloaded format=latex 2005.11.7)  9 NOV 2005 
19:41
.
.
.

{8r.enc}<C:\localtexmf\fonts\type1\monotype\s
abon\msbr8a.pfb><C:\localtexmf\fonts\type1
\monotype\sabon\msbri8a.pfb
Warning: pdflatex (file C:\localtexmf\fonts\type1
\monotype\sabon\msbri8a.pfb): 
532 bytes more than expected were ignored

Error: pdflatex (file C:\localtexmf\fonts\type1
\monotype\sabon\msbri8a.pfb): un
expected end of file
 ==> Fatal error occurred, the output PDF file is not 
finished!

----------------------------
If you need, I have all the 
necessary .pfb, .afm, .tfm, .fd, .vf, .map, .enc, .sty
 and a short .tex file to reproduce the problem. 
Anyway I attach them so you have them if you need.

Many thanks in advance

----------------------------------------------------------------------

>Comment By: Hartmut Henkel (hhenkel)
Date: 2005-11-09 23:29

Message:
Logged In: YES 
user_id=929

seems the font file msbri8a.pfb is broken. It is missing the
line

mark currentfile closefile

near the end. The other fonts in this family are ok! With
the missing line, pdftex can't find the end of the eexec
section. The above statements are normally part of any Type1
font, see the Type1 specification by Adobe.

Just compare your font with other .pfb's after disassembling
by t1disasm. Add above line at the right place, make a new
.pfb by t1asm -b and pdftex will happily use the font.

And complain to the font manufacturer! :-)

Regards, Hartmut


----------------------------------------------------------------------

Comment By: Hartmut Henkel (hhenkel)
Date: 2005-11-09 20:53

Message:
Logged In: YES 
user_id=929

it's likely that this is solved in a newer version. I can't
check without the font. Try to retest on 1.30.4 from MiKTeX.
Or you might send me the pack of test files to
hartmut_henkel at gmx dot de.

Regards, Hartmut

----------------------------------------------------------------------

You can respond by visiting: 
http://sarovar.org/tracker/?func=detail&atid=493&aid=450&group_id=106


More information about the ntg-pdftex mailing list