[NTG-pdftex] bug in XObject

Hans Hagen pragma at wxs.nl
Fri Jun 3 10:35:16 CEST 2005


Vit Zyka wrote:
> Hallo pdftexdevelopers,
> 
> there is a bug in \pdfxform. See the next example:
> -----------------------
> \pdfcompresslevel=0
> \footline={\hfill}%
> \setbox0\vbox{\hsize8.75cm\noindent Ahoj}
> \pdfxform attr{/Matrix [1.2 0.25 0.3 1 0 0]} 0
> \pdfrefxform\pdflastxform
> \end
> -------------------------
> The result XObject looks like:
> ------------------------
> 1 0 obj <<
> /Type /XObject
> /Subtype /Form
> /Matrix [1.2 0.25 0.3 1 0 0]
> /BBox [0 0 248.031 8.856]
> /FormType 1
> /Matrix [1 0 0 1 0 0]
> /Resources 6 0 R
> /Length 69
>  >>
> stream
> 1 0 0 1 0 -833.034 cm
> BT
> /F1 9.963 Tf 0 834.971 Td[(Aho)-55(j)]TJ
> ET
> endstream
> endobj
> ------------------------
> See the double /Matrix entry. That results in ignoring transformation by 
> Acrobat (R) v.6 and 7. (v.4 and v.5 is OK). I believe that it is 
> (exceptionally) bug in pdftex not in Acrobat ;)

pdftex is (and will) not parsing the content of attr, so the duplicate entry si 
a feature; conforming the specs acrobat should look at the first entry and if 
they broke that ...

Hans

-----------------------------------------------------------------
                                           Hans Hagen | PRAGMA ADE
               Ridderstraat 27 | 8061 GH Hasselt | The Netherlands
      tel: 038 477 53 69 | fax: 038 477 53 74 | www.pragma-ade.com
                                              | www.pragma-pod.nl
-----------------------------------------------------------------



More information about the ntg-pdftex mailing list