[NTG-pdftex] [ pdftex-Bugs-242 ] Assertion failure when including pdf file without embedded fonts

noreply at sarovar.org noreply at sarovar.org
Fri Jan 21 00:38:48 CET 2005


Bugs item #242, was opened at 2004-12-02 20:01
You can respond by visiting: 
http://sarovar.org/tracker/?func=detail&atid=493&aid=242&group_id=106

Category: Fonts
Group: v1.20b
Status: Open
Resolution: Fixed
Priority: 5
Submitted By: Nobody (None)
Assigned to: Hartmut Henkel (hhenkel)
Summary: Assertion failure when including pdf file without embedded fonts

Initial Comment:
See included shell script

----------------------------------------------------------------------

Comment By: Nobody (None)
Date: 2005-01-21 05:08

Message:
Logged In: NO 

I’ve already contacted the owner of LJBOOK.com and he 
doesn’t see a problem with it on his end. I don’t know if 
it has something to do with the PDF or not. I’m writing in 
English in the United States. I have Adobe Reader 6.0.

I’ve tried multiple times to make a copy of my Livejournal 
through ljbook.com without success. I have a lot of 
entries, all “friends only” or “private” from 2002 to 
2005. When I make the copy of my journal into the PDF, a 
majority of the words with apostrophes and “quotes” like 
I’ll, Don’t, She’s, Couldn’t, That’s, How’s, etc. gets 
replaced by a symbol that looks like a weird letter “a” 
with something on top of it. The actual apostrophe gets 
replaced with the symbol and makes those words look 
separated and weird. I’ve tried multiple times and the 
same problem occurs. It shows more in the years 2004 and 
2005 but it does show in the 2002 and 2003 entries also, 
when it’s in the PDF. I also tried those years on its own 
and get the same problem. I have the “Auto-convert older 
entries from” set correctly and the encodings set properly 
and still have the problem. Could you please help me out? 
I’m really in need to backup my journal and don’t know why 
almost all the words that have apostrophes are turning the 
apostrophes into that symbol when it’s in the PDF format. 
When it’s in my regular Livejournal, it’s perfect and 
doesn’t show that. Just when it’s backed up into the PDF.

Please help me out. I would really appreciate it a lot. 
Thank you very much in advance.

liveatshea at hotmail.com 



----------------------------------------------------------------------

Comment By: Hartmut Henkel (hhenkel)
Date: 2005-01-13 04:49

Message:
Logged In: YES 
user_id=929

This is a patch for file mapfile.c of pdftex-1.20, cleaning
up a few bugs introduced by patch-242c. The obsolete
qualifier "!" is removed from scanning. Blank handling
between qualifiers "<", "<<" and .enc and f_name names has
been re-introduced, to make it backward compatible and
compatible to the preferences of map file writers.

Please test carefully. Help welcome.

Regards, Hartmut

----------------------------------------------------------------------

Comment By: Martin Schröder (oneiros)
Date: 2004-12-22 20:23

Message:
Logged In: YES 
user_id=421

This has been fixed in 1.20b

----------------------------------------------------------------------

Comment By: Thomas Esser (tetex)
Date: 2004-12-03 05:00

Message:
Logged In: YES 
user_id=1230

I can reproduce this bug after
  updmap --setoption pdftexDownloadBase14 false

Thomas

----------------------------------------------------------------------

You can respond by visiting: 
http://sarovar.org/tracker/?func=detail&atid=493&aid=242&group_id=106


More information about the ntg-pdftex mailing list