[NTG-pdftex] pdfeTeX 1.20b-2.1: writet3 problem

The Thanh Han The Thanh Han <hanthethanh@myrealbox.com>
Wed, 12 May 2004 08:04:54 +0700


yes I am aware of this problem. Someone posted a bugfix of bbox
calculation (very long time ago). When I was digging my mail box
containing pdftex bug reports, I found that post and applied without
careful testing. My apology for that.

1.20a-rc3 no longer has this bug.

Regards,
Thanh

On Wed, May 12, 2004 at 01:50:41AM +0200, Hartmut Henkel wrote:
> Hi,
> 
> in pdftex as of teTeX 2.96.2 there seems to be a problem with reading pk
> fonts, e. g.
> 
> \font\aaa xbmc10 at 10pt \aaa hi \bye
> 
> (xbmc10.mf see pdfetex.web. BTW, this xbmc10.mf is missing in teTeX)
> 
> I get "bad pk file, expected pre" from readchar() of pkin.c, but the
> xbmc10.600pk is ok, starting with preamble 247. The problem is somehow,
> that the check_preamble is true even after the 1st byte read, so that
> later in pk file read suddenly a preamble check is done. This has
> somehow to do with t3_glyph_num in writepk() of writet3.c. The kludge,
> which seems to work, is to have some
> 
> boolean checkpreamble=true;
> 
> at the begin of writepk(), and then have the while loop like:
> 
>  while (readchar(checkpreamble, &cd) != 0) {
>             checkpreamble=false;
> 
> so that the header is only checked once at start of file read. But this
> might cover some problem with t3_glyph_num...
> 
> Regards Hartmut
> _______________________________________________
> ntg-pdftex mailing list
> ntg-pdftex@ntg.nl
> http://www.ntg.nl/mailman/listinfo/ntg-pdftex
>