<html xmlns:o="urn:schemas-microsoft-com:office:office" xmlns:w="urn:schemas-microsoft-com:office:word" xmlns:m="http://schemas.microsoft.com/office/2004/12/omml" xmlns="http://www.w3.org/TR/REC-html40"><head><meta http-equiv=Content-Type content="text/html; charset=utf-8"><meta name=Generator content="Microsoft Word 15 (filtered medium)"><style><!--
/* Font Definitions */
@font-face
        {font-family:"Cambria Math";
        panose-1:2 4 5 3 5 4 6 3 2 4;}
@font-face
        {font-family:Calibri;
        panose-1:2 15 5 2 2 2 4 3 2 4;}
/* Style Definitions */
p.MsoNormal, li.MsoNormal, div.MsoNormal
        {margin:0cm;
        margin-bottom:.0001pt;
        font-size:11.0pt;
        font-family:"Calibri",sans-serif;}
a:link, span.MsoHyperlink
        {mso-style-priority:99;
        color:blue;
        text-decoration:underline;}
a:visited, span.MsoHyperlinkFollowed
        {mso-style-priority:99;
        color:#954F72;
        text-decoration:underline;}
.MsoChpDefault
        {mso-style-type:export-only;}
@page WordSection1
        {size:612.0pt 792.0pt;
        margin:70.85pt 70.85pt 70.85pt 70.85pt;}
div.WordSection1
        {page:WordSection1;}
--></style></head><body lang=FR link=blue vlink="#954F72"><div class=WordSection1><p class=MsoNormal>Dear list,</p><p class=MsoNormal><o:p> </o:p></p><p class=MsoNormal>With latest ConTeXt beta (13-04-2019) I notice that font features seem ignored in page header rendering. (missing kern between Ps in « Psalme » and different Th in « Thimothee ».</p><p class=MsoNormal><o:p> </o:p></p><p class=MsoNormal>Anything I am doing wrong ?</p><p class=MsoNormal>Rendering is fine if \headerok is used.</p><p class=MsoNormal> </p><p class=MsoNormal>Any help would be appreciated.</p><p class=MsoNormal> </p><p class=MsoNormal>Thanks</p><p class=MsoNormal>Best regards</p><p class=MsoNormal> </p><p class=MsoNormal>Joseph</p><p class=MsoNormal><o:p> </o:p></p><p class=MsoNormal>\definefontfeature[base][mode=node, liga=yes, dlig=yes, hlig=yes, kern=yes]<o:p></o:p></p><p class=MsoNormal>\definefontfeature[xvicentury][]<o:p></o:p></p><p class=MsoNormal> <o:p></o:p></p><p class=MsoNormal>\definefontfamily[mainfont][serif][EBGaramond][features=base]<o:p></o:p></p><p class=MsoNormal> <o:p></o:p></p><p class=MsoNormal>\setupbodyfont[mainfont, 9pt]<o:p></o:p></p><p class=MsoNormal> <o:p></o:p></p><p class=MsoNormal>\showfontkerns<o:p></o:p></p><p class=MsoNormal> <o:p></o:p></p><p class=MsoNormal>\def\wrongheader{First book {\feature[-][xvicentury]v} Psalme De David. Thimothee.} %% \feature[-] seems to cause problems in header<o:p></o:p></p><p class=MsoNormal>\def\headerok{First book v Psalme De David. Thimothee.}<o:p></o:p></p><p class=MsoNormal> <o:p></o:p></p><p class=MsoNormal>\setupheadertexts[\wrongheader] %% kern/ligatures missing <---<o:p></o:p></p><p class=MsoNormal>% \setupheadertexts[\headerok] %% kern/ligatures ok <---<o:p></o:p></p><p class=MsoNormal> <o:p></o:p></p><p class=MsoNormal>\starttext<o:p></o:p></p><p class=MsoNormal> <o:p></o:p></p><p class=MsoNormal>\wrongheader %% all ok in main text<o:p></o:p></p><p class=MsoNormal> <o:p></o:p></p><p class=MsoNormal>\headerok<o:p></o:p></p><p class=MsoNormal> <o:p></o:p></p><p class=MsoNormal>\stoptext<o:p></o:p></p></div></body></html>