<div dir="ltr">Same problem, item (6) of email below, observed with arabtype font.  See attached.  MWE follows.<div><br></div><div>\definefontfamily [myfamily] [serif] [arabictypesetting] [features=arabic]<br>\setupbodyfont    [myfamily]<br>\setupalign[r2l]<br>\setupdirections[bidi=global,<wbr>method=two]<br><br>\setupmixedcolumns[register][<wbr>direction=reverse]<br>\setupregister[index][<br>  before=,after=,                                                                                                          <br>  command=\MyCommand,<br>  alternative=b,<div>  color=red,<br>]<br><br>\def\MyCommand#1{#1}                                                                                                       <br>%\def\MyCommand#1{\inframed[<wbr>frame=no]{#1}}  % this fixes the problem<br><br>\showboxes<br><br>\starttext<br>\index{آب}<br>\index{عذر}<div><span style="font-size:12.8px">\index[تک]{TEX}</span><br style="font-size:12.8px"><span style="font-size:12.8px">testing</span><br style="font-size:12.8px"><span style="font-size:12.8px">\placeindex</span><br style="font-size:12.8px"><span style="font-size:12.8px">\stoptext</span><div style="font-size:12.8px"><br></div></div></div></div><div style="font-size:12.8px"><br></div><div>any insights about other items in the previous email?</div><div><br></div><div>—MHB</div></div><div class="gmail_extra"><br><div class="gmail_quote">On Wed, Aug 17, 2016 at 10:48 PM, Mohammad Hossein Bateni <span dir="ltr"><<a href="mailto:bateni@gmail.com" target="_blank">bateni@gmail.com</a>></span> wrote:<br><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex"><div dir="ltr">Hello,<div><br></div><div>For a few days I have been playing with registers to generate an RTL index.  Beside sorting, I ran into the following.</div><div><br></div><div>1) How can I get the index section using \subject?  In some styles, I do not want to see the section number.</div><div><br></div><div>2) How can I get the Persian comma used instead of the English comma in page numbers and also before "see also"?  The first one I can fix by a hack but not the second one: defining a custom pagecommand that sets <span>\</span><span>registerpageseparatorsym<wbr>bol to the Persian comma</span>!  There is a TODO comment in strc-reg.mkiv that the comma customization has been planned.</div><div><br></div><div>3) In RTL registers, if an entry starts with an LTR char, the order of index entry and page number will be incorrect.  We had similar issues with section headings before.  I can "fix" this by setting pagestyle=\zwnj, but is there a more principled way to handle this?  See the MWE below.</div><div><br></div><div>4) Is there a way to define the style of "see also" different from pagestyle?  What if I want to distinguish "see also" from the actual entry this is referring to?</div><div><br></div><div>5) Currently I use <span>\setupmixedcolumns</span><span>[<wbr>register][direction=reverse] </span>t<wbr>o get the two-column register in the correct order.  What if I have two index registers, one for RTL and another for LTR?  Is there a way to set the direction key for a specific register?</div><div><br></div><div>6) In a two-column Persian index, using almost any (non-mono) font, some letter headings (those extending significantly below the baseline) end up with extra space below.  See attached PDF and the MWE.  (I could not reproduce this with DejaVuSans or ALM Fixed.)</div><br><br>\definefontfamily [myfamily] [serif] [Scheherazade] [features=arabic]<br>\setupbodyfont    [myfamily]<br>\setupalign[r2l]<br>\setupdirections[bidi=global,<wbr>method=two]<br><br>\setupmixedcolumns[register][<wbr>direction=reverse]<br>\setupregister[index][<br>  before=,after=,                                                                                                          <br>  command=\MyCommand,<br>  alternative=b,<div>  color=red,<br>]<br><br>\def\MyCommand#1{#1}                                                                                                       <br>%\def\MyCommand#1{\inframed[<wbr>frame=no]{#1}}  % this fixes the problem<br><br>\showboxes<br><br>\starttext<br>\index{آب}<br>\index{عذر}<div>\index[تک]{TEX}<br>testing<br>\placeindex<br>\stoptext<div><br></div><div><br></div><div>Some of the setups are to refute suspected causes.  Notice that using \inframed fixes the problem.</div><div><br><div>Thanks,</div><div>Hossein</div>















</div></div></div></div>
</blockquote></div><br></div>