<html>
  <head>
    <meta content="text/html; charset=utf-8" http-equiv="Content-Type">
  </head>
  <body bgcolor="#FFFFFF" text="#000000">
    <div class="moz-cite-prefix">On 2015-10-23 14:40, Rik Kabel wrote:<br>
    </div>
    <blockquote cite="mid:562A7F28.2050106@rik.users.panix.com"
      type="cite">
      <meta http-equiv="content-type" content="text/html; charset=utf-8">
      At Wolfgang’s request, a new thread for this subject. I have
      cleaned up the example from the July 5 posting, but the problems
      are the same as shown there. In July Alan suggested that there
      might a bug here, but nothing has been done to address it since
      then. Wolfgang suggested (<a moz-do-not-send="true"
        class="moz-txt-link-freetext"
        href="http://www.mail-archive.com/ntg-context%40ntg.nl/msg35580.html">http://www.mail-archive.com/ntg-context%40ntg.nl/msg35580.html</a>)
      that method=font is required for proper protrusion handling for
      quotations.<br>
      <ol>
        <li>When \setupdelimitedtext[quotation][method=font] is present
          <i>and </i><i>there is </i><i>no citation</i><i> in a
            footnote within a startquotation block and a bibliography is
            produced</i>, compilation proceeds normally.<br>
        </li>
        <li>When \setupdelimitedtext[quotation][method=font] is present
          <i>and </i><i>there is a citation</i><i> in a footnote within
            a startquotation block and a bibliography is produced,</i>
          the compilation complains of a missing right curly. When
          allowed to continue to completion the protrusion for the
          opening quotation marks does not match the protrusion for
          similar marks not produced through \startquotation. Citations
          in footnotes outside quotation blocks are not a problem.
          Without a bibliography (\placelistofpublications)<br>
        </li>
        <li>When \setupdelimitedtext[quotation][method=font] is present,
          the [right] option of \startblockquotation is treated as text
          within the quotation. This can be resolved by adding
          “leftmargin=” to the \setupdelimitedtext[quotation] command
          (but that complicates matters when you want other alignments).
          Similarly, the [left] and [middle] options are ignored as
          options and appear as text.<br>
        </li>
        <li>When “method=font” is not present, protrusion for block
          quotations (\startblockquotation … \stopblockquotation) is
          greater than and not aligned with other protrusion.</li>
        <li>When “method=font” is not present, protrusion for non-block
          quotations (\quotation{…}) is not done at all.<br>
        </li>
        <li>With the older bibliography system, footnotes in citations
          in quotation blocks do not cause a halt in compilation.<br>
        </li>
        <li>With the older bibliography system, item 3 is still a
          problem, that is, method=font appears to be inimical to the
          left, right, and middle options for \startblockquotation
          without regard to the bibliography system in use.<br>
        </li>
      </ol>
    </blockquote>
    Further testing shows that the failure to compile issue (#1 and #2
    above) is tied to processing @ARTICLE bib entries. The failure
    occurs in and out of footnotes and startquotation blocks. I really
    was too deep into a wrong view of the problem to see that before.
    That is pretty clearly a bug.<br>
    <br>
    The issue with method=font and left, right, middle (#3, #4, #5
    above) is still problematic. This is not tied to the bibliography
    system.<br>
    <br>
    -- <br>
    Rik<br>
  </body>
</html>