<html><head>
<meta content="text/html; charset=UTF-8" http-equiv="Content-Type">
</head><body bgcolor="#FFFFFF" text="#000000"><span></span><br>
<blockquote style="border: 0px none;" 
cite="mid:alpine.OSX.2.02.1506212333450.62444@nqv-znpobbx" type="cite">
  <div style="margin:30px 25px 10px 25px;" class="__pbConvHr"><div 
style="display:table;width:100%;border-top:1px solid 
#EDEEF0;padding-top:5px">   <div 
style="display:table-cell;white-space:nowrap;vertical-align:middle;width:100%">
        <a moz-do-not-send="true" href="mailto:adityam@umich.edu" 
style="color:#737F92 
!important;padding-right:6px;font-weight:bold;text-decoration:none 
!important;">Aditya Mahajan</a></div>   <div 
style="display:table-cell;white-space:nowrap;vertical-align:middle;">   
  <font color="#9FA2A5"><span style="padding-left:6px">22. Juni 2015 
05:35</span></font></div>    </div></div>
  <div style="color:#888888;margin-left:24px;margin-right:24px;" 
__pbrmquotes="true" class="__pbConvBody">On Sun, 21 Jun 2015, Aditya 
Mahajan wrote:
<br>
<br>
<br>Even the second example in strc-ref.mkvi does not work correctly.
<br>
<br>\starttext
<br>    \chapter{test}
<br>    \placefigure[here][xx:1]{}{\framed{one}} 
\placefigure[here][xx:2]{}{\framed{three}}
<br>    \placetable [here][xx:3]{}{\framed{two}} \placetable 
[here][xx:4]{}{\framed{four}}
<br>    \start
<br>        \in{fig}[xx:1] and \in{fig}[xx:2] \in{tab}[xx:3] and 
\in{tab}[xx:4]
<br>    \stop \blank \start
<br>        \setupreferencestructureprefix[default][prefix=no]
<br>        \in{fig}[xx:1] and \in{fig}[xx:2] \in{tab}[xx:3] and 
\in{tab}[xx:4]
<br>    \stop \blank \start
<br>        \setupreferencestructureprefix[float][default][prefix=no]
<br>        \in{fig}[xx:1] and \in{fig}[xx:2] \in{tab}[xx:3] and 
\in{tab}[xx:4]
<br>    \stop \blank \start
<br>        \setupreferencestructureprefix[figure][default][prefix=no]
<br>        \in{fig}[xx:1] and \in{fig}[xx:2] \in{tab}[xx:3] and 
\in{tab}[xx:4]
<br>    \stop \blank
<br>\stoptext
<br>
<br>The second case, (\setup...[default][prefix=no]) works correctly, 
but the 
last two cases (\setup...[float][default][prefix=no], etc) do not get 
rid 
of the prefix.
    <br>
  </div>
</blockquote>
Did you fix the typo in strc-ref.lua and regenrate the format?<br>
<br>
Wolfgang<br>
</body></html>