<div>
                    <font face="Courier New">Dear Group,
                </font></div><div><font face="Courier New"><br></font></div><div><font face="Courier New">Thank you for your time. I'm starting out with TeX/ConTeXt, but</font></div><div><font face="Courier New">want to arrive via LuaTeX (`luatex-plain.tex/fmt`). Managed to</font></div><div><font face="Courier New">build, move and use `luatex-plain`. Have the same problem under</font></div><div><font face="Courier New">MacOSX & Win7 (here is the Win-specific decription -- `%CTX%` is</font></div><div><font face="Courier New">my ConTeXt root):</font></div><div><font face="Courier New"><br></font></div><div><font face="Courier New">Placed some fonts under `%CTX%\tex\texmf-fonts\otf\minion\` &</font></div><div><font face="Courier New">`%CTX%\tex\texmf-fonts\otf\myriad`. Executed, the following</font></div><div><font face="Courier New">commands, </font><span style="font-family: 'Courier New';">recognising there might be redundancy, but not sure):</span></div><div><font face="Courier New"><br></font></div><div><font face="Courier New">    mtxrun --script fonts --update --force</font></div><div><font face="Courier New">    mtxrun --script fonts --update --simple</font></div><div><font face="Courier New">    mtxrun --script fonts --update</font></div><div><font face="Courier New">    mtxrun --script fonts --list --pattern=minion</font></div><div><font face="Courier New"><br></font></div><div><font face="Courier New">Result:</font></div><div><font face="Courier New"><br></font></div><div><div><font face="Courier New">    minionpro             minionprobold      MinionPro-Bold.otf</font></div><div><font face="Courier New">    minionprobold         minionprobold      MinionPro-Bold.otf</font></div><div><font face="Courier New">    minionproboldit       minionproboldit    MinionPro-BoldIt.otf</font></div><div><font face="Courier New">    minionprobolditalic   minionproboldit    MinionPro-BoldIt.otf</font></div><div><font face="Courier New">    minionproit           minionproit        MinionPro-It.otf</font></div><div><font face="Courier New">    minionproitalic       minionproit        MinionPro-It.otf</font></div><div><font face="Courier New">    minionpronormal       minionproit        MinionPro-It.otf</font></div><div><font face="Courier New">    minionproregular      minionproregular   MinionPro-Regular.otf</font></div></div><div><font face="Courier New"><br></font></div><div><font face="Courier New">`hello.tex` - luatex-plain test file:</font></div><div><font face="Courier New"><br></font></div><div><font face="Courier New">    %[luatex-plain] Hello</font></div><div><font face="Courier New">    %</font></div><div><font face="Courier New">    font\T =minionproregular at 12pt\T</font></div><div><font face="Courier New">    Hello world.</font></div><div><font face="Courier New">    \bye</font></div><div><font face="Courier New"><br></font></div><div><font face="Courier New">Executed:</font></div><div><font face="Courier New"><br></font></div><div><font face="Courier New">    luatex-plain hello.tex</font></div><div><font face="Courier New"><br></font></div><div><font face="Courier New">Result:</font></div><div><font face="Courier New"><br></font></div><div><font face="Courier New"><font>    </font>fonts : font with asked name 'minionproregular' </font></div><div><font face="Courier New">      is not found using lookup 'name'</font></div><div><font face="Courier New">    fonts : unknown font 'minionproregular', loading aborted</font></div><div><font face="Courier New">    ! Font \ch=minionproregular at 12pt not loadable: </font></div><div><font face="Courier New">      metric data not found or bad.</font></div><div><font face="Courier New"><br></font></div><div><font face="Courier New">Looked in `%CTX%\tex\texmf-cache\luatex-cache\generic\fonts\data`</font></div><div><font face="Courier New">at the file `luatex-font-names.lua`. The fonts were listed. Then</font></div><div><font face="Courier New">deleted the `luatex-font-names.luc` file, added the full paths</font></div><div><font face="Courier New">to the fonts in front of all the file names in the `.lua` file.</font></div><div><font face="Courier New"><br></font></div><div><font face="Courier New">Running `luatex-plain hello.tex` again, works now as expected (it</font></div><div><font face="Courier New">seems to recreate the `luatex-font-names.luc` automatically).</font></div><div><font face="Courier New"><br></font></div><div><font face="Courier New">Setting `OSFONTDIR` before font update and/or before running</font></div><div><font face="Courier New">`luatex-plain`, have no observable effect.</font></div><div><font face="Courier New"><br></font></div><div><font face="Courier New">So, I do have a manual fix/solution. But is there an easier way?</font></div><div><font face="Courier New"><br></font></div><div><font face="Courier New">Thanks in advance,</font></div>
                <div><div><font face="Courier New"><br></font></div><div><font face="Courier New">-- </font></div><div><font face="Courier New">AĆ­re Funvake</font></div><div><br></div></div>