[NTG-context] new upload

Pablo Rodriguez oinos at gmx.es
Mon Oct 17 19:12:28 CEST 2022


On 10/15/22 11:28, Hans Hagen via ntg-context wrote:
> […]
> just run twice as the script will pick up

Hi Hans,

I have tried updating ConTeXt in Windows this morning and I’m afraid it
hasn't worked.

Until I can manage this, I think I will download (to the extend that is
possible [and if this works at all]) a Win64 distribution using Linux64
with "--platform=win64".

The problem is clearly not the speed of the internet connection. I use
internet with the standard speed.

There are two things that strike me as possible causes.

1. Depending of which update is pending, the script announces a
different number of files to be downloaded.

The problem is that each individual file download seems to require a
complete connection.

I mean, it takes about ten seconds to establish a connection for each
file. It is irrelevant how big the file actually is.

After that, it isn’t much harder to download the LMTX binary than a tiny
text file.

For most files, they aren’t downloaded in the first connection (they may
require more than three downloads). It doesn’t seem to depend on size.

This is what makes it hard to reach even 10% in the download.

And even if some files may have been downloaded, once the script quits,
the already downloaded files need to be downloaded again (since the main
download process wasn’t completed).

2. The whole download is http instead of https.

Sorry, but this may be causing the delay in the connections (because
they may be being filtered by the company proxy [and I don’t want to ask]).

https://lmtx.pragma-ade.nl seems to be the only source used (in Windows)
and its certificate is only valid for lmtx.pragma-ade.com (according to
Firefox).

Even using "./install.sh --secure --platform=win64" (I’m on Linux now,
no Windows here), I get:

mtx-install     | instance : install-lmtx
mtx-install     | platform : windows
mtx-install     | system   : unix
mtx-install     | fetching
'http://lmtx.pragma-ade.com/install-lmtx//texmf.zip'
 […]
mtx-install     | fetching
'http://lmtx.pragma-ade.com/install-lmtx//texmf-context.zip'

I don’t know whether this is a bug or it is intended.

BTW, "local function checkurl()" on line 52 of mtx-install.lua ends with:

  and find(s,"rotocols")

I think it might read (although this doesn’t seem to change anything in
my case):

  and find(s,"protocols")

Is there anything that I could to to improve the download process?

Many thanks for your help,

Pablo


More information about the ntg-context mailing list