[NTG-context] synctex problem

Gavin gavinpublic at comcast.net
Sat Oct 15 21:14:15 CEST 2022


Hi Alan,

I have an almost identical set-up (M1, MacOS12.6, TexShop, useAlternatePath, useConTeXtSyncParser). One important difference, I use

sync method: SyncTeX (TeX ≥ 2010)

I’d recommend trying that. There are some other differences in my setup that probably are not important. At the beginning of my files (products and components)I only use the two lines

% !TEX useAlternatePath
% !TEX useConTeXtSyncParser

not the root and TS-program lines, but I don’t think that matters for your SynchTeX issue. Here is the engine I use for LMTX, just in case it has something helpful for you.

#!/bin/zsh
#
# This engine uses TeXShop's "Alternate Path", which is the variable "$3" below.
# Set the TeXShop's alternate path to your ConTeXt installation in
#  TeXShop's Preferences -> Engine -> Alternate Path
# Start ConTeXt source files with the lines:
#  % !TEX useAlternatePath
#  % !TEX useConTeXtSyncParser

export OSFONTDIR=/Library/Fonts/:/System/Library/Fonts:$HOME/Library/Fonts
export PATH="$3":$PATH
mtxrun --autogenerate --script context --synctex "$1”

I put that long comment in the engine because I share it with collaborators.

Hope that helps!

Gavin



> On Oct 15, 2022, at 12:00 PM, Alan Bowen via ntg-context <ntg-context at ntg.nl> wrote:
> 
> At the top of a single source file, I have the lines:
> % !TEX root = prd_Aestimatio-0301.tex 	% the root file
> 	% !TEX TS-program = ConTeXt2021
> 	% !TEX useAlternatePath
> 	% !TEX useConTeXtSyncParser
>    \setupsynctex[state=start, method=max]
> 
> Syncing works well enough—though I can see no difference between method =min and method=max, both highlight only a few words and not the entire text to be synced, but perhaps my expectations are out of line.
> 
> When I have these lines at the top of a component file and typeset the product file, I get a rootfile.synctex file, but syncing itself goes awry. Nothing happens when I sync from the PDf file to the component file, and when I sync from the component file to the product PDF, I get the correct page but no highlighting.
> 
> I am using TeXShop ver. 5.03— 
> 	sync method: Both Pdf Sync and Search
> 	Alternative Path: /Users/bowen1/Applications/LuaMetaTeX/tex/texmf-osx-arm64/bin
> 
> and  also the latest ConteXt (ver.  2022.10.15 10:37 LMTX)  under macOS 12.6 (Apple M1 Pro chip)
> 
> Note: the product file has only one  component file for now.
> 
> I suspect that I am missing something but am not sure where to look or what to do now. Any guidance will be much appreciated.
> 
> Alan
> 
> ___________________________________________________________________________________
> If your question is of interest to others as well, please add an entry to the Wiki!
> 
> maillist : ntg-context at ntg.nl / https://www.ntg.nl/mailman/listinfo/ntg-context
> webpage  : https://www.pragma-ade.nl / http://context.aanhet.net
> archive  : https://bitbucket.org/phg/context-mirror/commits/
> wiki     : https://contextgarden.net
> ___________________________________________________________________________________



More information about the ntg-context mailing list