[NTG-context] LMTX generates PDFs with non-working fonts on real printers

Hans Hagen j.hagen at xs4all.nl
Mon Oct 3 23:57:00 CEST 2022


On 10/3/2022 7:17 PM, Leah Neukirchen via ntg-context wrote:
> Hi,
> 
> I use LuaMetaTeX 2.10 20220918 + ConTeXt LMTX 2022.09.11.
> 
> Here's a tiny test document, I disabled PDF compression but it also
> doesn't work with the default settings.
> 
> \setupbackend[level=0,compresslevel=0]
> \starttext
> Just a line of text.
> \stoptext
> 
> When I print this "directly" (i.e. sending the raw PDF to the printer)
> on a Ricoh MP3053 or on a Samsung CLP-680DW, I just get an empty page.
> 
> The PDFs render fine on every PDF reader I could find.
> 
> Conversion to PostScript with pstopdf (poppler-22.07.0) and then
> sending the PS renders the document correctly on the printer.
> 
> PDFs generated directly from Context MKIV from TeXLive 2022 using
> LuaTeX 1.5 render fine on these printers.
> I've also printed PDFs from pdfTeX in the past fine.
> 
> I attached the non-working 'foo.pdf.mkix'
> and the working 'foo.pdf.mkiv' file.
> 
> I tried to disable font subsetting to debug this further, but I
> couldn't figure out how to do it.

subsetting should not be a problem and both files are subsetted  (lmxt a 
bit different but not fundamentally)

> Any ideas what I should try to help debug this?
i'm clueless ...

Hans

-----------------------------------------------------------------
                                           Hans Hagen | PRAGMA ADE
               Ridderstraat 27 | 8061 GH Hasselt | The Netherlands
        tel: 038 477 53 69 | www.pragma-ade.nl | www.pragma-pod.nl
-----------------------------------------------------------------


More information about the ntg-context mailing list