[NTG-context] debugging lmtx and firefox (was: TeXGyre Heros on Firefox)

juh+ntg-context at mailbox.org juh+ntg-context at mailbox.org
Fri Jul 22 12:37:23 CEST 2022


Dear all,

the firefox pdf viewer has problems with at least two sans serif fonts.

Using this mwe I get a bad display in ff with Gyre font and Alegreya Font.

%\definefontfamily[mainfont][sans][AlegreyaSans]
\definefontfamily[mainfont][sans][texgyreheros]
\setupbodyfont	[mainfont,12pt]
\startdocument
   \starttext
   \input lorem
\stoptext
\stopdocument

When I create a pdf from LibreOffice with these fonts I have a good display.

pdffonts shows different font inclusion:


pdffonts libreoffice.pdf
name                                 type              encoding 
emb sub uni object ID
------------------------------------ ----------------- ---------------- 
--- --- --- ---------
BAAAAA+TeXGyreHeros-Regular          Type 1            Builtin 
yes yes yes      9  0

pdffonts mwe.pdf
name                                 type              encoding 
emb sub uni object ID
------------------------------------ ----------------- ---------------- 
--- --- --- ---------
SOVKKO+TeXGyreHeros-Regular          CID Type 0C       Identity-H 
yes yes yes      1  0


Where Libreoffice has type "Type 1", lmtx has "CID Type 0C".

Where Libreoffice has encoding "Builtin", lmtx has "Identity-H".

I have no idea if the difference is the cause of the bad display.

Luckily chrome based browsers shows the fonts without any flaws.

But there are many Firefox users out there who never use a real 
pdf-viewer. I would like to show them a good result.

Any ideas how I can achieve this?

juh



More information about the ntg-context mailing list