[NTG-context] m-graph label

John Kitzmiller jkitzm at gmail.com
Thu Jul 21 23:56:45 CEST 2022


> On Sat, 16 Jul 2022 13:21:06 -0400
> John Kitzmiller via ntg-context <ntg-context at ntg.nl> wrote:
>
> > The horizontal axis label of mwe below has 0.0 (showing tenths; pdf
> > attached; filename is mwe.tex).
> >
> > I expected it to show -1, 0, 1, 2, 3, (integers only). Can this be
> > formatted?
> >
> > % -1 1
> > % 0 1
> > % 0 2
> > % 1 1
> > % 2 1
> > % 2 2
> > % 2 3
> > % 2 4
> > % 3 1
> > % 3 2
> >
> > \usemodule[m-graph]
> > \startMPpage[instance=graph, offset=5mm]
> > labeloffset:=3mm;
> > draw begingraph(8cm,4cm);
> >   setrange(-1.5,0.5,3.5,5);
> >   picture symbol ;
> >   symbol := image(draw fullcircle scaled 5mm withcolor red;);
> >   gdata("mwe.tex", v,
> >           clearxy;
> >             glabel(symbol,v1,v2) ;
> >            );
> >     frame.bot shifted(0,-2mm) ;
> >     autogrid(otick.bot,) shifted(0,-2mm);
> > endgraph;
> > \stopMPpage
> >
> > Thanks! John
>


> On Wed, Jul 20, 2022 at 9:48 AM Alan <braslau.list at comcast.net> wrote:
> % Autoform                       is the format string used by autogrid
> % Autoform_X, Autoform_Y         if defined, are used instead
>
> string Autoform ; Autoform = "%g";
>
> % string Autoform_X ; Autoform_X := "@.0e" ;
> % string Autoform_Y ; Autoform_Y := "@.0e" ;


Thanks Alan. I see those lines in the module listing, but could you provide
some guidance on usage? Can the (re)formatting be done from my input file,
or do I need to modify mp-grap.mpiv, or some other way?

(Apologies for double-dipping, but usage direction for the least-squares
fit extension in m-graph would be a gift.)
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mailman.ntg.nl/pipermail/ntg-context/attachments/20220721/0051561e/attachment.htm>


More information about the ntg-context mailing list