[NTG-context] lmtx installation paths not working

Jano Kula jano.kula at gmail.com
Tue Jun 14 13:20:06 CEST 2022


Hello list,

I cannot make fresh install of lmtx to work. The structure after unzipping:
C:\data\context\bin\beta
C:\data\context\bin\beta\bin
C:\data\context\bin\beta\tex
C:\data\context\bin\beta\tex\texmf
C:\data\context\bin\beta\tex\texmf-cache
C:\data\context\bin\beta\tex\texmf-context
etc.

First compilation of texfile is not working, so mtxrun --generate is the
friend.

C:\data>mtxrun --generate

These paths contain probably correct path (watch /beta):

resolvers       | resolving | variable 'SELFAUTOLOC' set to '
*C:/data/context/bin/beta/bin*'
resolvers       | resolving | variable 'SELFAUTODIR' set to '
*C:/data/context/bin/beta*'
resolvers       | resolving | variable 'SELFAUTOPARENT' set to '
*C:/data/context/bin*'
resolvers       | resolving | variable 'TEXMFCNF' set to ''
resolvers       | resolving | variable 'TEXMF' set to ''
resolvers       | resolving | variable 'TEXOS' set to 'beta'
resolvers       | resolving |

and the paths bellow have no */beta* from above, they are derived from
selfautoparent *C:/data/context/bin *(without /beta), so no surprise they
cannot be found.

resolvers       | resolving | using configuration specification
'home:texmf/web2c;selfautoparent:/texmf-local/web2c;selfautoparent:/texmf-context/web2c;selfautoparent:/texmf-dist/web2c;selfautoparent:/texmf/web2c'
resolvers       | resolving |
resolvers       | resolving | looking for regular 'texmfcnf.lua' on given
path 'C:/Users/jano/texmf/web2c' from specification 'home:texmf/web2c'
resolvers       | resolving | looking for regular 'texmfcnf.lua' on given
path *'C:/data/context/bin/texmf-local/web2c*' from specification
'selfautoparent:/texmf-local/web2c'
resolvers       | resolving | looking for regular 'texmfcnf.lua' on given
path '*C:/data/context/bin/texmf-context/web2c'* from specification
'selfautoparent:/texmf-context/web2c'
resolvers       | resolving | looking for regular 'texmfcnf.lua' on given
path '*C:/data/context/bin/texmf-dist/web2c*' from specification
'selfautoparent:/texmf-dist/web2c'
[... skip ...]
resolvers       | resolving | looking for regular 'texmfcnf.lua' on given
path
resolvers       | resolving |
resolvers       | resolving | warning: no lua configuration files found
resolvers       | resolving | no texmf paths are defined (using TEXMF)
resolvers       | resolving |
mtxrun          |
mtxrun          | elapsed lua time: 0.026 seconds

Do you have an idea how to fix problem?
I will be thankful for an advice, it is quite urgent (everything was
working yesterday).

Thank you,
Jano
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mailman.ntg.nl/pipermail/ntg-context/attachments/20220614/138b1b8c/attachment.htm>


More information about the ntg-context mailing list