[NTG-context] Math functions not typeset inside MetaPost

Mikael Sundqvist mickep at gmail.com
Tue Apr 19 16:52:30 CEST 2022


On Tue, Apr 19, 2022 at 3:59 PM śrīrāma via ntg-context
<ntg-context at ntg.nl> wrote:
>
> Hi Hans,
>
> [I am sending this again since the previous mails regarding were sent during
> the weekend].
>
> I am on the most recent upload of LMTX [2022.04.15 20:20]. However, when I try
> to use math functions inside MetaPost strings, the function is not typeset
> correctly. Please consider the following MWE:
>
>   \starttext
>     \startMPcode
>     draw textext("\m{\max_i x_i}");
>     \stopMPcode
>   \stoptext
>
> which produces the output attached here as an image. Instead of the mfunction
> maxᵢ xᵢ
> some form of the string mathfunctionhandlelabel is typeset.
>
> I tried to inspect \math_function_handle_label [math-ini] and also mp-mlib and
> mlib-pps but could not figure out what is going wrong. I wonder if there is a
> backslash missing somewhere. I am a little worried since I use MetaFun in
> conjunction with maths and could not figure out what the issue is.
>
> Please see the original post by Dalyoung here:
>   https://mailman.ntg.nl/pipermail/ntg-context/2022/105462.html
>
> Please advise.
>
> Thank you,
>   Sreeram___________________________________________________________________________________

Thanks, this will be fixed in the next upload (that will take place
soon as far as I've heard).

Best regards, Mikael


More information about the ntg-context mailing list