[NTG-context] Setting up zint on a mac with macOS Montery Version 12.3.1

Bruce Horrocks ntg at scorecrow.com
Sun Apr 10 23:26:10 CEST 2022


Hi Keith,

> On 10 Apr 2022, at 14:49, Keith McKay via ntg-context <ntg-context at ntg.nl> wrote:
> 
> Hi All
> 
> I have been struggling today trying to setup and use the Barcode module zint in ConTeXt and failed. I have followed the instructions on the wiki ( https://wiki.contextgarden.net/Barcodes ) but with some changes as follows. Which maybe why I failed.
> 
> 1) I downloaded Zint using Homebrew since I'm using macOS, and installed it according to the instructions.
> 
> 
> 2) Since I'm using LMTX I looked for the file libzint.dylib and found it in /opt/homebrew/Cellar/zint/2.10.0/lib . This is different from the path given on the wiki. The directory contained three files, two of which were aliases,  libzint.2.10.dylib and libzint.dylib, and an exe file libzint.2.10.0.0.dylib

You have Hombrew installed in a non-standard location. Mine is in /usr/local/Cellar with the executables linked into /usr/local/bin.

But, assuming other Homebrew commands work when run from Terminal then you might still be okay.

> 3) I created the path $TEXROOT/tex/texmf-osx-64/bin/lib/luametatex/zint and copied libzint.2.10.0.0.dylib into but replaced dylib with 'so' as suggested on the wiki instructions. So I basically added  lib/luametatex/zint to texmf-osx-64/bin .

"Yes" to creating the path but "no" to copying. Create a symbolic link instead.

So, in Terminal:

  $ cd $TEXROOT/tex/texmf-osx-64/bin/lib/luametatex/zint

  # In my case I used the following:
  $ ln -s /usr/local/Cellar/zint/2.10.0/lib/libzint.dylib libzint.so

  # For you with Homebrew in a different location, try:
  $ ln -s /opt/homebrew/Cellar/zint/2.10.0/lib/libzint.dylib libzint.so

Then steps 4 and 5 as below. I ran the MWE below: the ISBN worked, the ISBNX didn't, the QR code did. This is on Monterey.

> 4) I ran mtxrun --generate to update the database.
> 
> 5) I ran the MWE below but no barcode appeared. The console output shows:
>  
> 
> modules         > using user prefixed file 'libs-imp-zint'
> modules         > 'zint' is loaded
> 
>  however further down the output it gives:
> 
> 
> optional        > unable to locate library 'libzint'
> 
> I have tried renaming libzint2.10.0.0.so to libzint.so, but still no barcode. Is their something I am missing? Tips or hints appreciated.
> Best Wishes
> Keith McKay
> 
> %%%%%%%%%%%%%% MWE %%%%%%%%
> \usemodule[zint]
> \starttext
> \barcode[alternative=isbn,text=9783865419026,width=4cm]
> \barcode[alternative=isbnx, text=9783865419026, width=4cm]
> \barcode[alternative=qrcode, text={https://wiki.contextgarden.net}, width=3cm]
> \stoptext

—
Bruce Horrocks
Hampshire, UK



More information about the ntg-context mailing list