[NTG-context] New upload is DOA on my M1 Mac

Bruce Horrocks ntg at scorecrow.com
Mon Mar 14 00:53:50 CET 2022



> On 12 Mar 2022, at 19:55, Gavin via ntg-context <ntg-context at ntg.nl> wrote:
> 
> Hi Hans,
> 
>> i uploaded a new installer / uopdates with mojca's bin
> 
> Thanks for putting that together. Unfortunately, same result:
> 
> 	TeXShop produces no output in console
> 	"mtxrun —generate” produces "zsh: killed mtxrun --generate"
> 
> 
> JP,
> 
> The control-open trick seemed like a good idea, but it didn’t change my results. TeXShop findes an old version from TeXLive, probably because it can’t use the new one. In Terminal I still get “permission denied."

The instance of mtxrun that TeXShop finds is entirely down to path settings and/or TexShop preferences settings (in its 'engine' files) and nothing to do with the security permissions.

Regarding the security permissions there is something else to check: go to System Preferences -> Security & Privacy -> Privacy tab -> Full Disk Access.
Make sure 'TeXShop.app' and 'Terminal.app' are both in the list.

If that still doesn't work then there is one more thing but it will be a PITA. :-(

And that is to install Xcode and the Xcode developer tools. This then gives you another Privacy entry in the left hand list called "Developer Tools" and, above the apps list on the right, the description reads "Allow the apps below to run software locally that does not meet the system's security policy." Add Terminal.app here.

—
Bruce Horrocks
Hampshire, UK



More information about the ntg-context mailing list