[NTG-context] Why isn't bold + italics working together?

Wolfgang Schuster wolfgang.schuster.lists at gmail.com
Sat Jan 29 18:01:00 CET 2022


Joel via ntg-context schrieb am 29.01.2022 um 15:46:
> I am finishing the final touches on a manuscript, which I hope to send 
> to a publisher later today and noticed this problem where bold and 
> italic text isn't rendered at the same time.
> 
> I am using the EB Garamond font in my document. I set it up exactly as 
> shown below. Strangely, bold works, italics works, but when bold and 
> italics are together, it only display in italics, it doesn't display a 
> bold italic text. I've confirmed the `EBGaramond-BoldItalic.otf` font is 
> present and seems just fine. I've also tried by just using the default 
> ConTeXt font and the error still appears, also in 
> live.contextgarden.net. I tried searching the mailing list, as this 
> seems like something that must have come up, but couldn't find any 
> question about this.
> 
> Why won't it render both?

See Adams answer.

> \starttypescript[serif] [garamond]
> \definefontsynonym[Serif] [file:~/.fonts/12/EBGaramond-Regular.otf]
> \definefontsynonym[SerifBold] [file:~/.fonts/12/EBGaramond-Bold.otf]
> \definefontsynonym[SerifItalic] [file:~/.fonts/12/EBGaramond-Italic.otf]
> \definefontsynonym[SerifBoldItalic] [file:~/.fonts/12/EBGaramond-BoldItalic.otf]
> \stoptypescript

Don't use absolute paths in \definefontsynonym, when you use a local 
folder for your font files set the path with \usefontpath.

%%%% begin snippet
\usefontpath [~/fonts/12/]

\starttypescript [serif] [garamond]
     \definefontsynonym [Serif] [file:EBGaramond-Regular.otf]
     ...
\stoptypescript
%%%% end snippet

Wolfgang


More information about the ntg-context mailing list