[NTG-context] [LMTX] fonts problem (again)

Hans Hagen j.hagen at xs4all.nl
Sun Feb 21 17:05:33 CET 2021


On 2/21/2021 4:45 PM, kaddour kardio wrote:
> 
> Hi! Once again i'm unable to load my system's font which is working well 
> with MKIV.
> 
> i have followed the steps :
> export 
> OSFONTDIR=~/.local/share/fonts:/usr/share/fonts:/usr/share/texmf/fonts/opentype/
> mtxrun --generate
> mtx run --make
> mtxrun --script fonts --reload
> 
> without success.
> This problem occurred  to me since december 2020, i update LMTX weekly 
> from the archlinux user repo (aur) binary.
> Any suggestions?
Not without more info ... here I get something

fonts           | names | variable 'OSFONTDIR' specifies path 
'c:/windows/fonts'
fonts           | names | variable 'fontconfig file' specifies path 
'c:/windows/fonts'
fonts           | names | globbing path 'c:/windows/fonts/**.otf'
fonts           | names | identifying system font files with suffix 'OTF'
fonts           | names | globbing path 'c:/windows/fonts/**.OTF'

what is that at your end? (As I never rely on system fonts I have no 
linux box with a setup to test it.)

(making a copy - or link - in <sometexroot>/texmf-fonts/data/... could 
also work)

Hans

-----------------------------------------------------------------
                                           Hans Hagen | PRAGMA ADE
               Ridderstraat 27 | 8061 GH Hasselt | The Netherlands
        tel: 038 477 53 69 | www.pragma-ade.nl | www.pragma-pod.nl
-----------------------------------------------------------------


More information about the ntg-context mailing list