[NTG-context] LMTX problem with XML

Pablo Rodriguez oinos at gmx.es
Mon Feb 15 17:16:17 CET 2021


On 2/14/21 10:32 PM, Hans Hagen wrote:
> On 2/14/2021 9:24 PM, Pablo Rodriguez wrote:
>
>> But I‘m afraid it will take some time before I can provide a minimal
>> sample showing the issue.
>
> We have plenty of time in these lock down days.

Many thanks for your reply, Hans.

Might I suggest a couple of implementations in ConTeXt for these
lockdown days?

Parallel streams (both in pages and columns) have been already mentioned
here by some other users.

BTW, a nice version of three streams in two facing pages can be seen at
https://archive.org/details/aristo-teles-poetica/page/n54/mode/1up.

The other suggestion would be page registers for footnotes (such as in
http://www.faenumpublishing.com/uploads/2/3/9/8/23987979/hippocrates_on_airs_waters_and_places_-_hayes_and_nimis_june_2013.pdf#page=126).

>> Many thanks again for your excellent work with ConTeXt,
> Maybe some bad tuc file? Sometimes wiping it helps.

I overlooked that XML output was different from a newer version of
pandoc (which I use in Windows).

The new version included the same class for parent and child element
(parent <div> and child <h1>). Of course, this lead to crash, since my
lpath selection took for granted that only the parent <div> had that class.

In my case, copying everything to a new "testing" file (or bunch of
files) and start removing lines is the way to discover what is wrong in
the code.

Many thanks for your help,

Pablo
--
http://www.ousia.tk


More information about the ntg-context mailing list