[NTG-context] Missing images in Wiki?

Andres Conrado Montoya Acosta elandi at chiquitico.org
Fri Jan 22 20:41:05 CET 2021


This is one example:

https://wiki.contextgarden.net/Command/externalfigure

However, now I checked the source, and the image files are there... and
they are being correctly linked, but the image attributes width and height
are set to zero. Maybe something wrong with lazy loading?

Example in html code:

<img class="image-lazy-loaded" alt="" style=""
src="/wikiteximage/966d36e3a607022bcbae59654239a147.png" srcset="" *width="0"
height="0"*>


El vie, 22 ene 2021 a las 6:00, <ntg-context-request at ntg.nl> escribió:

> Send ntg-context mailing list submissions to
>         ntg-context at ntg.nl
>
> To subscribe or unsubscribe via the World Wide Web, visit
>         https://mailman.ntg.nl/mailman/listinfo/ntg-context
> or, via email, send a message with subject or body 'help' to
>         ntg-context-request at ntg.nl
>
> You can reach the person managing the list at
>         ntg-context-owner at ntg.nl
>
> When replying, please edit your Subject line so it is more specific
> than "Re: Contents of ntg-context digest..."
>
>
> Today's Topics:
>
>    1. Missing images in Wiki? (Andres Conrado Montoya)
>    2. Re: Missing images in Wiki? (Taco Hoekwater)
>    3. new lmtx / fonts (Hans Hagen)
>    4. \doassign variable - updates not picked up (Werner Hennrich)
>
>
> ----------------------------------------------------------------------
>
> Message: 1
> Date: Thu, 21 Jan 2021 14:30:59 -0500
> From: Andres Conrado Montoya <andresconrado at gmail.com>
> To: mailing list for ConTeXt users <ntg-context at ntg.nl>
> Subject: [NTG-context] Missing images in Wiki?
> Message-ID:
>         <CAGhDZhBhKYygadgykbrqDm_VEqHDA=
> z7sh-Ng53xaxs6LR_DyQ at mail.gmail.com>
> Content-Type: text/plain; charset="utf-8"
>
> It seems a lot of image examples from the wiki are gone now. Most articles
> lost many images. Is this on purpose?
>
> --
> Andrés Conrado Montoya
> -------------- next part --------------
> An HTML attachment was scrubbed...
> URL: <
> http://mailman.ntg.nl/pipermail/ntg-context/attachments/20210121/8ba7f748/attachment-0001.htm
> >
>
> ------------------------------
>
> Message: 2
> Date: Fri, 22 Jan 2021 09:06:51 +0100
> From: Taco Hoekwater <taco at bittext.nl>
> To: mailing list for ConTeXt users <ntg-context at ntg.nl>
> Subject: Re: [NTG-context] Missing images in Wiki?
> Message-ID: <712D4F56-8CBC-4BDF-ADAC-86FACD1D2DB6 at bittext.nl>
> Content-Type: text/plain;       charset=utf-8
>
>
>
> > On 21 Jan 2021, at 20:30, Andres Conrado Montoya <
> andresconrado at gmail.com> wrote:
> >
> > It seems a lot of image examples from the wiki are gone now. Most
> articles lost many images. Is this on purpose?
>
> Seems unlikely, but provide a few examples, please. I will check.
>
>> Taco Hoekwater              E: taco at bittext.nl
> genderfluid (all pronouns)
>
>
>
>
>
> ------------------------------
>
> Message: 3
> Date: Fri, 22 Jan 2021 09:50:50 +0100
> From: Hans Hagen <j.hagen at xs4all.nl>
> To: mailing list for ConTeXt users <ntg-context at ntg.nl>
> Subject: [NTG-context] new lmtx / fonts
> Message-ID: <ab638a78-912f-c604-8c6e-9206193fe511 at xs4all.nl>
> Content-Type: text/plain; charset=utf-8; format=flowed
>
> Hi,
>
> I uploaded a new lmtx. I'm still playing a bit with metafonts so there
> are two new files
>
> context --global meta-imp-demo.mkxl
> context --global meta-imp-clock.mkxl
>
> Both show a bit. The question is, do we need / want more like this? What
> kind of interfaces are best? It's mostly about used defined symbols that
> are proper characters and efficiently used.
>
> Hans
>
> PS. The clock one has a hidden cut'n'paste feature that only works on
> acrobat which of course then makes it a kind of useless feature (plenty
> of them by now) because when, e.g. a  mupdf bases viewer doesn't support
> this after all these years it's could as well be kept out of the standard.
>
>
>
> -----------------------------------------------------------------
>                                            Hans Hagen | PRAGMA ADE
>                Ridderstraat 27 | 8061 GH Hasselt | The Netherlands
>         tel: 038 477 53 69 | www.pragma-ade.nl | www.pragma-pod.nl
> -----------------------------------------------------------------
>
>
> ------------------------------
>
> Message: 4
> Date: Fri, 22 Jan 2021 09:48:58 +0100
> From: Werner Hennrich <wehe at gmx.at>
> To: ntg-context at ntg.nl
> Subject: [NTG-context] \doassign variable - updates not picked up
> Message-ID: <88b0bb87-972e-0664-1e29-71e7b05388a7 at gmx.at>
> Content-Type: text/plain; charset="utf-8"; Format="flowed"
>
> Hello everyone,
>
> I'm using ConTeXt  (ver: 2020.09.20 23:02 LMTX) and have to have
> conditional page headers based on specific content criteria. To achive
> this I'd like to get some global variables in TeX, change their values
> several times throughout the document and have my macro for the header
> read them and act accordingly (like skip the header at all, change a
> color, etc).
>
> As a basis for this I established the following pattern in an iolated
> test case:
>
>     \def\setHeaderVar[#1]{
>     \doassign[header][myvar=#1]
>     \message{setHEADER: '#1'}
>     }
>     \def\getHeaderVar{\headermyvar}
>     \setupheadertexts[\setups{page:header}]
>     \startsetups page:header
>     HEADER: myvar=\getHeaderVar
>     \stopsetups
>     \starttext
>     \setHeaderVar[initval]
>     page: 1
>     \page
>     \setHeaderVar[aaaaa]
>     page: 2
>     \page
>     \setHeaderVar[bbbbb]
>     page: 3
>     \page
>     \setHeaderVar[cccc]
>     page: 4
>     \page
>     \setHeaderVar[]
>     page: 5
>     \stoptext
>
> This works as expected and the header-macro prints the updated value.
> But when I put the same pattern in my big environment-file, I can see
> the variable being updated with different values (console), but the
> header always puts out just the variable's initial value - so the
> variable is read but it's updates aren't picked up by the header macro.
> Peeking into console, log & tuc didn't raise any idea yet as to what is
> going wrong...
>
> Any idea what is happening and how I can fix this?
>
> Any hints on how I can track this down?
>
> Thanks a lot,
> Werner Hennrich, Vienna AT
>
>
> -------------- next part --------------
> An HTML attachment was scrubbed...
> URL: <
> http://mailman.ntg.nl/pipermail/ntg-context/attachments/20210122/b5413c6c/attachment-0001.htm
> >
>
> ------------------------------
>
> Subject: Digest Footer
>
>
> ___________________________________________________________________________________
> If your question is of interest to others as well, please add an entry to
> the Wiki!
>
> maillist : ntg-context at ntg.nl /
> http://www.ntg.nl/mailman/listinfo/ntg-context
> webpage  : http://www.pragma-ade.nl / http://tex.aanhet.net
> archive  : https://foundry.supelec.fr/projects/contextrev/
> wiki     : http://contextgarden.net
>
> ___________________________________________________________________________________
>
>
> ------------------------------
>
> End of ntg-context Digest, Vol 199, Issue 53
> ********************************************
>


-- 
Andrés Conrado Montoya
http://chiquitico.org
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mailman.ntg.nl/pipermail/ntg-context/attachments/20210122/ee533be3/attachment-0001.htm>


More information about the ntg-context mailing list