[NTG-context] Error setting up ConTeXt in MacTeX 2020

Otared Kavian otared at gmail.com
Fri Sep 18 11:20:15 CEST 2020

Hi Felix,

Some time ago I encountered the same problem and we had a thread on this list about this:


The problem on my Mac came from the fact that a directory
existed (installed by MacPorts, without me knowing it…) where ConTeXt tries to find a format, while there is none.
I removed that directory and then I could use ConTeXt from MacTex 2020.

Best regards: Otared

> On 18 Sep 2020, at 09:41, Felix Krause <contact at flyx.org> wrote:
> Hi all,
> with MacTeX 2020 on a newly installed Mac, I have the problem that ConTeXt doesn't work anymore:
> $ context file.tex
> mtx-context     | warning: no format found, forcing remake (commandline driven)
> […] snip lots of lines
> resolvers       | formats | changing to format path '/var/folders/rj/hfjmjx796q102y4v23vh038c0000gp/T/luatex-cache/context/a86c089b384a3076dc514ba966a1fac9/formats/luatex'
> resolvers       | formats | unable to change to format path '/var/folders/rj/hfjmjx796q102y4v23vh038c0000gp/T/luatex-cache/context/a86c089b384a3076dc514ba966a1fac9/formats/luatex'
> mtx-context     | error, no format found with name: cont-en, aborting
> system          | total runtime: 5.315 seconds
> The ConTeXt docs <https://wiki.contextgarden.net/Running_Mark_IV> say that I should run mtxrun --generate, which seems to run successfully, and context --make, which finishes with the same „unable to change format path“ error (I believe this is what context automatically does when compiling my file, hinted by the „no format found. forcing remake“ message). I tried explicitly running context --make cont-en which yields the same result. The given path does exist on my hard drive.
> I don't even know if the „unable to change format path“ message is actually an error, but I have no other indicator of what goes wrong. The only line that explicitly says „error“ is the one I get when trying to process the file.
> Interestingly, I have another Mac where I upgraded from MacTeX 2019 to MacTeX 2020 and everything works there.
> I made sure that everything is up-to-date with the TeX Live Utility.
> How can I fix this problem?
> Regards,
> Felix
> ___________________________________________________________________________________
> If your question is of interest to others as well, please add an entry to the Wiki!
> maillist : ntg-context at ntg.nl / http://www.ntg.nl/mailman/listinfo/ntg-context
> webpage  : http://www.pragma-ade.nl / http://context.aanhet.net
> archive  : https://bitbucket.org/phg/context-mirror/commits/
> wiki     : http://contextgarden.net
> ___________________________________________________________________________________

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mailman.ntg.nl/pipermail/ntg-context/attachments/20200918/4a476d6e/attachment-0001.htm>

More information about the ntg-context mailing list