[NTG-context] LMTX and soft links (Linux)

Pablo Rodriguez oinos at gmx.es
Mon Jul 6 19:26:45 CEST 2020

On 7/5/20 10:16 PM, Jairo A. del Rio wrote:
> Indeed, it works. A fast "cp -rs" solved it. Anyways, I'd rather prefer
> a less "manual" method. Thank you very much, Pablo.

Hi Jairo,

glad to read it helped.

But an open question (to Hans, Wolfgang and other LMTX developers) is
why softlinks in Linux (in Unix, my guess) only work for files and not
for directories. Sorry, but this doesn’t make sense to me.

Many thanks for your help,


> El dom., 5 de jul. de 2020 a la(s) 14:52, Pablo Rodriguez escribió:
>     On 7/5/20 9:14 PM, Jairo A. del Rio wrote:
>     > I'm using both LMTX from the ConTeXt standalone installation and a TeX
>     > Live installation. Since I'm using binaries from the standalone (and
>     > added LMTX to path, etc.), I created soft links in texmf-modules via
>     >
>     > ln -s /usr/local/texlive/2020/texmf-dist/tex
>     ~/lmtx/tex/texmf-modules/tex
>     >
>     > and similar (lmtx is my directory for the standalone).
>     >
>     > LuaTeX finds files without any issues. However LuaMetaTeX gives the
>     > following error:
>     >
>     > runtime error : input file (name of file) is not found, quitting
>     >
>     > The same result is for modules, .sty files and .tex files. Is this
>     > intentional, a bug in LMTX, or is a better solution possible? In case
>     > it's useful, I'm working with Ubuntu 20.04. Thank you a lot.
>     Hi Jairo,
>     I experience something very similar in Linux too.
>     LMTX follows softlinks to files, but no softlink to directories.
>     I don’t know why this happens, but it behaves this way.
>     Just in case it helps,
>     Pablo


More information about the ntg-context mailing list