[NTG-context] Emoji color fonts not working on LMTX/Context MKIV

Jairo A. del Rio jairoadelrio6 at gmail.com
Wed May 20 12:26:08 CEST 2020

I've tried the following from the manuals and adapted some code to see if
it works:


The emoji has no color when compiled with LuaTeX. Furthermore, the log
includes a lot of lines like the ones below:

fonts > svg conversion > executing runner 'otfsvg': inkscape
--export-area-drawing --shell > temp-otf-svg-shape.log

fonts > svg conversion > processing 1829 svg containers

xml > core > load error: invalid xml file - parsed text

With LMTX it gives an error about mlib-svg.


\definefontfeature[bitmap] [default][sbix=yes]
\definefontfeature [colored] [default]

What I get is:

fonts > png conversion > processing 3374 png containers

sh: 1: gm: not found

sh: 1: gm: not found

sh: 1: gm: not found sh: 1: gm: not found


and the same line repeating itself

close source > level 1, order 3, name

! error: (file /usr/share/fonts/truetype/noto/NotoColorEmoji.ttf) (ttf):
loca table not found

LMTX prints a file without any emoji.

Only Twemoji Mozilla and Segoe UI Emoji worked for me, so, what am I doing

I'm working with Ubuntu 20.04 LTS x86_64 and Inkscape 0.92.5 (2060ec1f9f,
2020-04-08) in case it helps. Thank you in advance.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mailman.ntg.nl/pipermail/ntg-context/attachments/20200520/febc4873/attachment.htm>

More information about the ntg-context mailing list