[NTG-context] Setting up macvim in mac os catalina to work with LMTX

janerik.hagglof janerik.hagglof at bahnhof.se
Thu Apr 23 07:19:32 CEST 2020

I think I managed to get the work done by putting the settings in ~.vim/after/ftplugin/context.vimSo The problem is solved, thanks to your answers.The rest of the problem seems not to be related to this list, such as how do I use .vimrc in the correct way so to keep default global settings and just tweaking them locally.Med Vänlig Hälsning Jan-Erik Hägglöf
-------- Originalmeddelande --------Från: Jan-Erik Hägglöf <janerik.hagglof at bahnhof.se> Datum: 2020-04-22  21:50  (GMT+01:00) Till: mailing list for ConTeXt users <ntg-context at ntg.nl> Ämne: Re: [NTG-context] Setting up macvim in mac os catalina to work with LMTX I managed to typeset with success by typing in:let g:context_mtxrun = 'PATH=$HOME/context-osx-64/tex/texmf-osx-64/bin:$PATH mtxrun’:ConTeXtWhen I put this into my .vimrc file nothing is working, do not even find the context commands, so I removed the .vimrc and then it worked again.So the question is where do I put this line permanent because it is strange to type this every time I want to typeset something.RegardsJanne22 apr. 2020 kl. 16:49 skrev Nicola <nvitacolonna at gmail.com>:On 2020-04-21, Jan-Erik Hägglöf <janerik.hagglof at bahnhof.se> wrote:Hi !I am curious about testing macvim and it seems doing fine in editmode. But how do i set up the typesetting engine?As far as I understand, there is, the command :ConteXt with guidancefrom the wiki https://wiki.contextgarden.net/Vim<https://wiki.contextgarden.net/Vim>But I do not understand how to customize it to be directed to the pathto my engineI’ve installed the LMTX in /Users/janneman/context-osx-64/I haven't tried LMTX yet, but you may configure the path to the ConTeXtexecutable you want to use by setting `g:context_mtxrun`, e.g.:    :let g:context_mtxrun='/path/to/context/mtxrun'Then, executing :ConTeXt will run the configured command. You may alsodefine shell enviroment variables, if needed. For instance, I haveconfigured Vim to use my installation of ConTeXt Beta as follows:   :let g:context_mtxrun='PATH=$HOME/path/to/context-beta/tex/texmf-osx-64/bin:$PATH mtxrun'The installation works fine in TeXshop but still an error shows up inmacvim and the message dissappears very quick so there is not muchtime to read the cause of error.You may show a log of Vim messages by typing :messages.If you post the error message, I may better diagnose your issue.I have created the subdirectory .vim/ftplugin/ and put the context.vim file therealso the corresponding in .vim/compiler/context.vimwhich is copied from the program located in/usr/local/Cellar/macvim/8.2-163/MacVim.app/Contents/Resources/vim/runtimeThat's unnecessary. MacVim's runtime path is searched by default.I recommend that you remove the files that you have copied into ~/.vim.ConTeXt in Vim works out of the box.Nicola___________________________________________________________________________________If your question is of interest to others as well, please add an entry to the Wiki!maillist : ntg-context at ntg.nl / http://www.ntg.nl/mailman/listinfo/ntg-contextwebpage  : http://www.pragma-ade.nl / http://context.aanhet.netarchive  : https://bitbucket.org/phg/context-mirror/commits/wiki     : http://contextgarden.net___________________________________________________________________________________
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mailman.ntg.nl/pipermail/ntg-context/attachments/20200423/8d3d609f/attachment-0001.htm>

More information about the ntg-context mailing list