[NTG-context] mtxrun fontloader in recent standalone

Benjamin Buchmuller benjamin.buchmuller at gmail.com
Wed Apr 22 22:48:43 CEST 2020

I’ve just updated to the most recent standalone 

ConTeXt  ver: 2020.01.30 14:13 MKIV beta  fmt: 2020.4.22 (LuaTeX 1.11.1)

and I’m running now into troubles with system font indexing:

mtxrun --script fonts --reload

locates fonts in macOS directories appropriately (*.afm fonts placed in .../tex/texmf-fonts are not found, but at the moment I don’t care too much), however it resolves only to a single font variant for *.ttc instead of all variants:

mtxrun --script fonts --list --all --pattern=helvetica

helvetica                         helvetica                    helveticalightoblique             /System/Library/Fonts/Helvetica.ttc                    6
helveticalightoblique             helvetica                    helveticalightoblique             /System/Library/Fonts/Helvetica.ttc                    6
helveticaneuedeskinterfaceheavy   helveticaneuedeskinterface   helveticaneuedeskinterfaceheavy   /System/Library/Fonts/HelveticaNeueDeskInterface.ttc   10
helveticaneuethinitalic           helveticaneue                helveticaneuethinitalic           /System/Library/Fonts/HelveticaNeue.ttc                14

As a consequence, when I run

\definefontfamily[mainface][ss][Helvetica Neue]
\setupbodyfont[mainface, 12pt, sans]

I get the light oblique variant instead of the regular one. I have tried to fix this via a 

\definefontfamily[mainface][ss][Helvetica Neue][tf=style:normal]

but apparently I understand too little about this setup altogether …

Thanks already for any suggestions!


More information about the ntg-context mailing list