[NTG-context] layers and \llap

Henri Menke henrimenke at gmail.com
Tue Nov 19 21:48:15 CET 2019


On 11/20/19 3:16 AM, Pablo Rodriguez wrote:
> Hi Hans,
> 
> this comes from a previous message about an issue with \llap and layers.
> 
> Here is the sample:
> 
>     \defineviewerlayer[print][state=stop,printable=yes]
>     \defineviewerlayer[view][state=start,printable=no]
> 
>     \starttext
>     \startviewerlayer[view]\color[red]{\TeX}\stopviewerlayer%
>     \startviewerlayer[print]\llap{\ConTeXt}\stopviewerlayer%
> 
>     \input zapf
>     \stoptext
> 
> If the layer with \llap is placed last, disabling the view layer
> disables all the text.
> 
> Everything works fine if the layer with \llap is placed first.
> 
> I guess this might be a bug.

Works for me on both Evince and Foxit Reader.  I can't test Adobe because I'm
on Linux.

Try also \dontleavehmode\llap{\ConTeXt} because \llap by itself does not start
a paragraph.

Cheers,
Henri

> 
> Many thanks for your help,
> 
> Pablo
> --
> http://www.ousia.tk
> ___________________________________________________________________________________
> If your question is of interest to others as well, please add an entry to the Wiki!
> 
> maillist : ntg-context at ntg.nl / http://www.ntg.nl/mailman/listinfo/ntg-context
> webpage  : http://www.pragma-ade.nl / http://context.aanhet.net
> archive  : https://bitbucket.org/phg/context-mirror/commits/
> wiki     : http://contextgarden.net
> ___________________________________________________________________________________
> 


More information about the ntg-context mailing list