[NTG-context] developer not verified error

Henri Menke henrimenke at gmail.com
Mon Nov 18 22:32:25 CET 2019


On 11/17/19 5:09 AM, Mojca Miklavec wrote> First I thought that we would have troubles with the binaries as soon
> as GateKeeper was introduced (not sure which macOS version started
> causing troubles), but somehow there were none, which at least came as
> a pleasant surprise to me. Maybe this has to do with the fact that
> anything running inside Terminal has somewhat higher permissions than
> regular app bundles. (I know that Audacity doesn't allow recording
> unless you run it from the Terminal, for example.)

In macOS Catalina Apple introduced “notarization”, i.e. anything you
install has to have Apple's blessing, otherwise it will refuse to
install and show you a message that it is malware.  Dick Koch,
maintainer of MacTeX ran into the same problems, as he presented at
TUG2019 and described in the corresponding TUGboat article:

    http://tug.org/TUGboat/tb40-2/tb125koch-harden.pdf

> I'm curious if that will work. I don't yet dare to upgrade to Catalina
> (in some ways the OS is worse with each new version).

I don't use macOS myself, but it seems that the quality of the latest
release is absolutely abysmal.

    https://tyler.io/broken/

Cheers, Henri


More information about the ntg-context mailing list