[NTG-context] LMTX issue with multple question blocks

Rik Kabel context at rik.users.panix.com
Thu Nov 7 17:36:44 CET 2019


On 11/7/2019 11:06, Hans Hagen wrote:
> On 11/7/2019 3:50 PM, Jan Willem Flamma wrote:
>> Dear list members,
>>
>> The below MWE runs fine and generates a usable PDF.
>>
>> If I uncomment the second question block and run the MWE on a OS X 
>> system it generates an unusable PDF and a nearly empty log file:
>>
>> open source     > level 1, order 1, name 'cont-yes.mkiv'
>> system          >
>> system          > ConTeXt  ver: 2019.10.28 18:57 MKIV beta  fmt: 
>> 2019.11.7  int: english/english
>> system          >
>> system          > 'cont-new.mkiv' loaded
>> open source     > level 2, order 2, name 
>> '/Users/JW/context/tex/texmf-context/tex/context/base/mkiv/cont-new.mkiv'
>> system          > beware: some patches loaded from cont-new.mkiv
>> close source    > level 2, order 2, name 
>> '/Users/JW/context/tex/texmf-context/tex/context/base/mkiv/cont-new.mkiv'
>>
>> system          > files > jobname 'co-intro', input './co-intro', 
>> result 'co-intro'
>> fonts           > latin modern fonts are not preloaded
>> languages       > language 'en' is active
>> system          > synctex functionality is enabled, expect 5-10 pct 
>> runtime overhead!
>> open source     > level 2, order 3, name './co-intro.tex'
>> fonts           > preloading latin modern fonts (second stage)
>> fonts           > 'fallback modern-designsize rm 12pt' is loaded
>> open source     > level 3, order 4, name 'knuth.tex'
>> close source    > level 3, order 4, name 'knuth.tex'
>>
>> I cannot reproduce the problem on a Windows system.
>>
>> Can somebody on an OS X system check and confirm the issue?
> What if you wipe the tuc file?
>
> No message?
>
> Hans

I can confirm the same problem on a Win64 problem. I get the same log 
file (with 2019.10.29 15:09 for the version and my file/directory names).

There is a console message that is, perhaps, meaningful:

    This is LuaMetaTeX, Version 2.00.0
    runtime error : input file 'virtual://block.question.' is not found,
    quitting
    mtx-context     | fatal error: return code: 1

-- 
Rik

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mailman.ntg.nl/pipermail/ntg-context/attachments/20191107/b2cf1075/attachment-0001.html>


More information about the ntg-context mailing list