[NTG-context] issue splitting tables and horizontal mode

Pablo Rodriguez oinos at gmx.es
Sun Oct 20 12:36:48 CEST 2019


On 10/20/19 11:49 AM, Wolfgang Schuster wrote:
> Pablo Rodriguez schrieb am 18.10.2019 um 16:23:
>> [...]
>> When splitting extreme tables, I cannot use \dontleavehmode.
> 1. What is the purpose of \dontleavehmode in your example?

Sorry, Wolfgang, I forgot to mention.

\dontleavehmode is required to center the table when
\startmakeup[standard][align=center].

> 2. Why do you try to split a table in a makup environment (which will
> never work)?

\setupxtable[split=yes] is a general setup for the whole document.

I mean, I don’t want a table in the document to be stuck between pages.

Only sometimes I have makeups with tables. And this was my first issue
with the conflicting general setup.

As written in my previous message, there was no clash some time (well,
five years 😅) ago.

>> Since this worked before, am I missing something or is this a bug?
> It isn't a bug but a side effect of the way how split=yes works.
>
> The normal splitters uses a simple placement method where each table row
> is placed below each other. To prevent unwanted white space between the
> lines \nointerlineskip is used but the command works only a vertical
> mode. With \dontleavehmode like in your example you force horizontal
> mode for the table which results in the error message.

Many thanks for your explanation.

Pablo
--
http://www.ousia.tk


More information about the ntg-context mailing list