[NTG-context] \startitemize + "joinedup" ("nowhite") not working in footnotes?

context at vivaldi.net context at vivaldi.net
Mon Oct 7 08:25:41 CEST 2019


Hello,

anyone to confirm/explain/fix the vertical gap?

Lukas


On 2019-10-02 14:40, context at vivaldi.net wrote:
> Hello,
> 
> in the following sample there is unwanted vertical gap between text
> "Foo" and the first item "- bar" in the footnote 1 (and also between
> "Bar" and "- bar") - see red arrows.
> 
> The same code used outside the footnote behaves as expected - there is
> no vertical space.
> 
> Is there anything special about handling itemization inside footnotes?
> 
> My code:
> 
> ----
> \def\T{%
>   \startitemize[joinedup,nowhite]
>     \item bar
>     \item baz
>   \stopitemize
> }
> 
> \def\U{%
>   Foo
>    \T
>   Bar
>    \T
> }
> 
> \starttext
>   \U
> 
>   \startitemize
>     \item Item\footnote{\U}
>   \stopitemize
> \stoptext
> ----
> 
> Best regards,
> 
> Lukas
> ___________________________________________________________________________________
> If your question is of interest to others as well, please add an entry
> to the Wiki!
> 
> maillist : ntg-context at ntg.nl / 
> http://www.ntg.nl/mailman/listinfo/ntg-context
> webpage  : http://www.pragma-ade.nl / http://context.aanhet.net
> archive  : https://bitbucket.org/phg/context-mirror/commits/
> wiki     : http://contextgarden.net
> ___________________________________________________________________________________


More information about the ntg-context mailing list