[NTG-context] Error during installation of LMTX

Hans Hagen j.hagen at xs4all.nl
Tue Oct 1 10:11:07 CEST 2019


On 9/30/2019 8:26 PM, Mojca Miklavec wrote:
> On Mon, 30 Sep 2019 at 20:04, Jan U. Hasecke wrote:
>>
>> I tried to update or install LMTX today and get this error:
>>
>> /lib/x86_64-linux-gnu/libm.so.6: version `GLIBC_2.29' not found
>> (required by /home/juh/context-linux-64/bin/mtxrun)
>>
>> I am running debian 10 buster.
> 
> This could be related to Hans updating the Ubuntu version on WSL on
> his computer recently (if that's the source of the distributed
> binaries).

for linux it still is (as it also populates some other places)

> We do have binaries on
>      http://dl.contextgarden.net/build/luametatex/x86_64-linux/
> which should work on Debian 9 (cmake on Debian 8 is too old and it
> would require a bit more tricks to support the version that old), but
> I'm not sure what you need to do to use them as a drop-in replacement
> during "bootstrapping" phase.
> 
> This should probably be answered by Hans.
so i need to pick up bins from the farm (need to set that up here) ... i 
tried to make a static which bumps the binary to 14 MB and then tried 
lto which takes a while to finish but then bring it down to 6MB ... (so 
maybe some day we need an extra static tree for linuxes of all kind)

Hans


-----------------------------------------------------------------
                                           Hans Hagen | PRAGMA ADE
               Ridderstraat 27 | 8061 GH Hasselt | The Netherlands
        tel: 038 477 53 69 | www.pragma-ade.nl | www.pragma-pod.nl
-----------------------------------------------------------------


More information about the ntg-context mailing list