[NTG-context] Error during installation of LMTX

Mojca Miklavec mojca.miklavec.lists at gmail.com
Mon Sep 30 20:26:20 CEST 2019


On Mon, 30 Sep 2019 at 20:04, Jan U. Hasecke wrote:
>
> I tried to update or install LMTX today and get this error:
>
> /lib/x86_64-linux-gnu/libm.so.6: version `GLIBC_2.29' not found
> (required by /home/juh/context-linux-64/bin/mtxrun)
>
> I am running debian 10 buster.

This could be related to Hans updating the Ubuntu version on WSL on
his computer recently (if that's the source of the distributed
binaries).

We do have binaries on
    http://dl.contextgarden.net/build/luametatex/x86_64-linux/
which should work on Debian 9 (cmake on Debian 8 is too old and it
would require a bit more tricks to support the version that old), but
I'm not sure what you need to do to use them as a drop-in replacement
during "bootstrapping" phase.

This should probably be answered by Hans.

Mojca


More information about the ntg-context mailing list