[NTG-context] Problem of displaying a date with a macro

Aditya Mahajan adityam at umich.edu
Wed Aug 28 16:33:56 CEST 2019


On Wed, 28 Aug 2019, Fabrice Couvreur wrote:

> Hello,
> The date display is incorrect : I get day 28 instead of day 2.
> Thank you
> Fabrice
>
> \defineframed
>    [headerframed]
>    [frame=off,
>     height=fit,
>     width=fit]
>
>  \definecolor[ColorA][0.8(white)]
>
>
>  \startsetups [headertext]
>
>    \setupheadertexts
>      [{\startframed [headerframed]
>      [foregroundstyle=bold,background=framewithshadow]
>      \getvariable{headertext}{title}
> n\high{o}\,\getvariable{headertext}{number}
>      \stopframed}]
>
>    \setupheadertexts
>      [{\startframed [headerframed]
>      [align=flushleft,foregroundstyle=]
>       Lycée LA SALLE, Lille\\
>       \getvariable{headertext}{location}
>       \stopframed}]
>
>      [{\startframed [headerframed]
>          [align=flushright,foregroundstyle=]
>
> \date[d=\getvariable{headertext}{day},m=\getvariable{headertext}{month},y=\getvariable{headertext}{year}]
>          \stopframed}]
>
>  \stopsetups
>
>  \setvariable{headertext}{set}{\directsetup{headertext}}
>
> \startuseMPgraphic{framewithshadow}
> path p;
> p:=origin--(OverlayWidth,0)--(OverlayWidth,OverlayHeight)--(0,OverlayHeight)--cycle;
> fill p shifted (2,-2);
> fill p withcolor 0.8white;
> draw p;
> setbounds currentpicture to p;
> \stopuseMPgraphic
>
> \defineoverlay[framewithshadow][\useMPgraphic{framewithshadow}]
>
> \starttext
> \setvariables
>   [headertext]
>   [title={Devoir maison},
>    number={6},
>    day={02},
>    month={09},
>    year={2019},
>    location={Seconde B},
>    time={}]
> \input knuth
> \stoptext

There was a bug with the \date macro which I had reported a few days ago. 
This appears to be related to that. Should be fixed in the next beta.

Aditya


More information about the ntg-context mailing list