[NTG-context] Bug with jobs.file.run?

Aditya Mahajan adityam at umich.edu
Sun Aug 25 13:47:55 CEST 2019


Hi,

There was a typo in the test file (but it does not change the behavior). I 
am attaching the correct test file.

Aditya

On Sat, 24 Aug 2019, Aditya Mahajan wrote:

> Hi,
>
> I use jobs.file.run in t-filter to cache the results so that the external 
> filters are only run if the content has changed. For some reason, this is not 
> working but I cannot figure out why? Repeating the same steps as t-filter 
> manually works, but something goes wrong when I use the t-filter interface.
>
> See the attached test.tex file.
>
> When I run
>
>   context test.tex
>   context test.tex | grep run
>
> I get
>
> graphics        > run > processing file, no changes in 'test.md', not 
> processed
>
> graphics        > run > processing file, changes in 'test-temp-pandoc-0.tmp', 
> processing forced
>
> Notice that the first run is the manual job.files.run and the second run is 
> the one from t-filter.
>
> The test file contains a fix, which is simply a copy-paste of the relavant 
> code from graph-fil.lua. When I run
>
>        context --mode=fix test.tex
> 	context --mode=fix test.tex | grep run
>
>
> I get
>
> graphics        > run > processing file, no changes in 'test.md', not 
> processed
>
> graphics        > run > processing file, no changes in 
> 'test-temp-pandoc-0.tmp', not processed
>
>
> So, I am not sure what is going wrong, and why is it getting fixed if I 
> simply copy the definition of jobs.file.run. Any hints?
>
> Thanks,
> Aditya
-------------- next part --------------
A non-text attachment was scrubbed...
Name: test.tex
Type: application/x-tex
Size: 2208 bytes
Desc: 
URL: <http://mailman.ntg.nl/pipermail/ntg-context/attachments/20190825/f02a7f94/attachment.tex>


More information about the ntg-context mailing list