[NTG-context] grid+formulas: bug or expected behavior?

Luca Donetti donetti at gmail.com
Fri May 31 20:46:19 CEST 2019


Dear all,
I'm typesetting a document with grid layout and some formulas, like in the
minimal example below:

%%%%%%%%%%%%%%%%%%%%%%%%%%%%
\setuplayout[grid=yes]
\showgrid

\starttext
\input knuth
%\blank
\startformula
  a = b + c
\stopformula
\input knuth
\stoptext
%%%%%%%%%%%%%%%%%%%%%%%%%%%%

I don't have any specific need for the alignment of the formula with
respect to the grid, but I expect the text below the formula to be on the
grid. However, I've not been able to achieve that with any of the layout
options described in the latest "details.pdf" manual: in all cases I've
tried the text below the formula doesn't "sit" on the grid.

While I do not understand this behavior, I've thought that it could be the
intended one, because this is what happens in chapter 4 of the "details"
manual. Then, I noticed that in older versions of the same manual (for
example the one included in texlive 2017) the behavior shown in chapter 4
is the one I expect: the text after formulas is aligned to the grid. So I'm
a bit puzzled: should the text after formulas be aligned to the grid or
not? Is this a (known?) bug or intended behavior?

If this is the expected behavior, I can live with that because by trial and
error I found a workaround. If I employ a \blank command before the formula
(as in the commented line in the above example), the text after the formula
is "correctly" aligned.

Thank you in advance.

LD
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mailman.ntg.nl/pipermail/ntg-context/attachments/20190531/130597c2/attachment.html>


More information about the ntg-context mailing list