[NTG-context] bug in beta from 2019.05.25 10:45

Hans Hagen j.hagen at xs4all.nl
Mon May 27 19:41:15 CEST 2019


On 5/27/2019 7:18 PM, Pablo Rodriguez wrote:
> On 5/26/19 10:12 PM, Hans Hagen wrote:
>> On 5/26/2019 9:52 PM, Pablo Rodriguez wrote:
>> [...]
>> What if you wipe the whole cache?
> 
> I’m afraid it doesn’t work either.
> 
> But this is weird. I’m able to typeset whole books from XML sources with
> environments using luajittex.
> 
>> I see you use luajittex. What with luatex?
> 
> It works perfectly fine with luatex.

So there is some mess up at your end then ... wrong format? There is no 
fundamental difference with luajittex (unless making the format fails 
but that should be visible). I use lmtx myself but run the test suite 
with both engines before an update, just to be sure.

> Probably I should move to pure LuaTeX.

As lmtx will not use luajit (in fact it uses lua 5.4) that is a good 
idea anyway. To slowly migrate. Of course context mkiv will keep working 
with luajittex as long as that will be provided (when luatex ever moves 
to lua 5.4 it might become too cumbersome, currently I can work around 
the fundamental differences but it's not always pretty).

I'm still not sure how to proceed, with a duplicate code base or not, or 
maybe just assume a frozen regular install and a further developed lmtx 
one. The performance gain of luajittex over luametatex is for context 
not that impressive any more. We'll see once the pending issues with 
lmtx are solved.

Hans

-----------------------------------------------------------------
                                           Hans Hagen | PRAGMA ADE
               Ridderstraat 27 | 8061 GH Hasselt | The Netherlands
        tel: 038 477 53 69 | www.pragma-ade.nl | www.pragma-pod.nl
-----------------------------------------------------------------


More information about the ntg-context mailing list